Bug #55782

RTE Image Wizard with white space above tabs

Added by Marcin Sągol almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-02-07
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If we enable images in RTE and open the wizard we can see that there is a 10px heigh white space above tabs. This is caused by top margin of the table that contains tabs (#typo3-tabmenu) but also that body not covers this area.

Please check attached screenshot.

I suggest also to increase tabs width because the localized text is sometime rendered in 2 lines.

rte_image_wizard_margin_issue.jpg View (208 KB) Marcin Sągol, 2014-02-08 00:05


Related issues

Related to TYPO3 Core - Bug #55773: Consistent look for the element browser in RTE and link input fields Closed 2014-02-07

Associated revisions

Revision 4beeebe2 (diff)
Added by Benni Mack almost 5 years ago

[BUGFIX] TYPO3 and RTE Link wizard with white space above tabs

Problem: In Internet Explorer and Google Chrome, white space appears
above tabs in the TYPO3 Link wizard and in the RTE Link and Image
dialogues.
Solution: Replace top margin of tab menu with padding in container.

Resolves: #55782
Releases: master, 6.2
Change-Id: I6817b83999115f2037b42bf398fdaa53af96c4dc
Reviewed-on: http://review.typo3.org/27614
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

Revision 73429bd1 (diff)
Added by Benni Mack almost 5 years ago

[BUGFIX] TYPO3 and RTE Link wizard with white space above tabs

Problem: In Internet Explorer and Google Chrome, white space appears
above tabs in the TYPO3 Link wizard and in the RTE Link and Image
dialogues.
Solution: Replace top margin of tab menu with padding in container.

Resolves: #55782
Releases: master, 6.2
Change-Id: I6817b83999115f2037b42bf398fdaa53af96c4dc
Reviewed-on: http://review.typo3.org/36352
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Stanislas Rolland almost 6 years ago

Marcin Sągol wrote:

If we enable images in RTE and open the wizard we can see that there is a 10px heigh white space above tabs. This is caused by top margin of the table that contains tabs (#typo3-tabmenu) but also that body not covers this area.

Perhaps this was fixed in current master. The RTE image wizard tabs now look just like the Link wizard tabs and the RTE link wizard tabs.

#2 Updated by Stanislas Rolland almost 6 years ago

Marcin Sągol wrote:

I suggest also to increase tabs width because the localized text is sometime rendered in 2 lines.

I think this would make tabs too wide. I think the current tab is set wider than the other ones. Hence, in the French localization, for example, some tabs have titles on two lines when inactive, but on one line when active. I think this is adequate.

#3 Updated by Stanislas Rolland almost 6 years ago

Marcin Sągol wrote:

If we enable images in RTE and open the wizard we can see that there is a 10px heigh white space above tabs. This is caused by top margin of the table that contains tabs (#typo3-tabmenu) but also that body not covers this area.

Ah! I see. This is in Internet Explorer, right? Also in Chrome. The problem is the same in the TYPO3 Link Wizard....

#4 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27614

#5 Updated by Stanislas Rolland almost 6 years ago

  • Assignee set to Stanislas Rolland

#6 Updated by Stanislas Rolland about 5 years ago

  • Assignee deleted (Stanislas Rolland)

#7 Updated by Stanislas Rolland about 5 years ago

  • Status changed from Under Review to New

#8 Updated by Tymoteusz Motylewski almost 5 years ago

works fine on v.7, but haven't check on 6.2.9

#9 Updated by Stanislas Rolland almost 5 years ago

@Tymoteusz: you mean that the problem is fixed in v.7?

#10 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/27614

#11 Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36352

#12 Updated by Benni Mack almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Benni Mack almost 5 years ago

  • Sprint Focus set to On Location Sprint

#14 Updated by Anja Leichsenring almost 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#15 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF