Project

General

Profile

Actions

Bug #56293

closed

Mailform element

Added by Ok Z4uit over 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2014-02-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

A while ago I wanted to test my Typo3 6.1.7 website in IE 11, since one of the editors uses that browser on default. Unfortunately, the Mailform element wizard does not behave like it should. After a post on the mailinglist I was asked to file a ticket at Forge.

The problem
If I open the form editor of the mailform content element in Internet Explorer 11, the saved entries are not shown. They are selectable, but not visible. A blue selection pane appears, although it is not heigh enough to show any content. The small text balloon which contains the edit/delete buttons normaly is also not properly displayed.

I tried this in the two systems:

- typo3 6.1.7 (php 5.3.27 and mysql 5.0.8, windows server)
- typo3 6.1.1 (php 5.4.12 and mysql 5.6.12, wampserver)

When a new form element is added, it is visible, even upon saving. However, as soon as the form editor is closed and re-opened, the added field that was visible turns as the others. In firefox (26.0) there are no problems of this kind.

To clarify, I added a set of screenshots.

Hopefully, this is fixable, until then I'll ask the editor to use another browser (no problems in Firefox, Safari or Chrome).

Best,

Adriaan


Files

form_bug_IE11.jpg (106 KB) form_bug_IE11.jpg Markus Klein, 2014-02-26 22:05

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #55774: ExtJS 3.4.1 does not recognize IE 11 as Internet ExplorerClosed2014-02-07

Actions
Actions #1

Updated by Markus Klein over 10 years ago

I fear this is another instance of the IE 11 detection issue of our ExtJS version.

Actions #2

Updated by Stanislas Rolland over 10 years ago

Markus Klein wrote:

I fear this is another instance of the IE 11 detection issue of our ExtJS version.

Not sure, since the backend uses IE 10 compatibility.

Actions #4

Updated by Ok Z4uit over 10 years ago

If I check the backend source code I only see IE9 compatibility:

<meta http-equiv="X-UA-Compatible" content="IE=9" />

Might that be a problem as well? Or do I mix things up now?

Actions #5

Updated by Riccardo De Contardi about 9 years ago

  • Status changed from New to Needs Feedback

Is this still valid? Could you check with the latest TYPO3 version? (6.2.12) ?

Actions #6

Updated by Wouter Wolters almost 9 years ago

  • Status changed from Needs Feedback to Closed

No feedback for 3 months. Closing this issue now.

If you think this is not the right decision, please open a new ticket.

Actions #7

Updated by Björn Jacob almost 9 years ago

  • Category changed from Backend User Interface to Form Framework
Actions

Also available in: Atom PDF