Project

General

Profile

Actions

Bug #55774

closed

ExtJS 3.4.1 does not recognize IE 11 as Internet Explorer

Added by Stanislas Rolland over 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2014-02-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

ExtJS 3.4.1 does not recognize IE 11 as Internet Explorer.

Hence Ext.isIE is false.

This is supposed to be fixed in ExtJS 3.4.2 only available to Sencha Support Subscribers:
http://www.sencha.com/products/extjs3/download/


Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #55775: RTE fails to load in IE 11 with "Access denied"ClosedStanislas Rolland2014-02-07

Actions
Related to TYPO3 Core - Bug #56192: RTE cannot run in IE 11 with ExtJS 3.4.1ClosedStanislas Rolland2014-02-21

Actions
Related to TYPO3 Core - Bug #56293: Mailform elementClosed2014-02-25

Actions
Related to TYPO3 Core - Task #63150: Set X-UA-Compatible meta tag for BEClosedBenni Mack2014-11-23

Actions
Related to TYPO3 Core - Bug #66140: Problem with IE11 and saving (can be reproduced in ext:news)Closed2015-03-30

Actions
Actions #1

Updated by Stanislas Rolland over 10 years ago

  • Category changed from Miscellaneous to RTE (rtehtmlarea + ckeditor)
Actions #2

Updated by Markus Klein over 10 years ago

Don't we have somebody with a good contact to the Sencha guys, such that we get this version quickly?

Actions #3

Updated by Markus Klein over 10 years ago

Stanislas, you might want to bring this to everybody's attention on the Core list?

Actions #4

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27427

Actions #5

Updated by Stanislas Rolland over 10 years ago

  • Category changed from RTE (rtehtmlarea + ckeditor) to Miscellaneous
  • Status changed from Under Review to New
Actions #6

Updated by Stanislas Rolland over 10 years ago

At the moment, the only workaround I can see is to force IE 11+ to behave like IE 10 by use of meta tag

<meta http-equiv="X-UA-Compatible" content="IE=10" />

In TYPO3 6.2, this meta tag is already added in the backend.

In the frontend, the meta tag would need to be added whenever the ExtJs libs are added on the page and the client is IE 11+. Not sure how to do this when there is non-cached content on the page.

Note: this meta tag needs to be added very early for IE to take it into account, probably before any css and js. So additionalHeaderData cannot be used for this tag.

Actions #7

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27758

Actions #8

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27758

Actions #9

Updated by Markus Klein over 10 years ago

  • Status changed from Under Review to Accepted
Actions #10

Updated by Stefan Neufeind over 10 years ago

  • Status changed from Accepted to Resolved

imho resolved with merged patch https://review.typo3.org/27776

Actions #11

Updated by Stanislas Rolland over 10 years ago

  • Status changed from Resolved to New

This is not resolved until ExtJS is updated to 3.4.2 or until ExtJS is not used in the TYPO3 backend.

Actions #12

Updated by Lorenz Ulrich over 9 years ago

Stefans solution doesn't work e.g. if the RTE is loaded dynamically in the iFrame.

Actions #13

Updated by Lorenz Ulrich over 9 years ago

What is the status of the ExtJS update anyway?

Actions #14

Updated by Lorenz Ulrich over 9 years ago

After some Slack communication with Mathias Schreiber and Alexander Stehlik:

Since it's improbable that TYPO3 will "buy" ExtJS 3.4.2 (which ships IE 11 detection), it makes sense to patch ExtJS. ExtJS is compressed with the YUI Compressor. Every ExtJS file comes in two variants in typo3/contrib/extjs, the compressed file and the uncompressed file suffixed with "-debug".

The IE 11 detection needs to be built in to all files containing it. There is a StackOverflow article with the solution.

Actions #15

Updated by Gerrit Code Review over 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37766

Actions #16

Updated by Lorenz Ulrich over 9 years ago

This can be tested as follows:

  • Login to TYPO3 with IE11.
  • Open the console (F12).
  • Go to the Emulation tab and set Document mode to "Edge (Standard)".
  • Go to the console.

Enter the following commands (of course without : false or : true at the end) - the detection doesn't work correctly:

  • Ext.isIE: false
  • Ext.isGecko: true
  • Ext.isIE10p: false

After applying the patch, reload and test again:

  • Ext.isIE: true
  • Ext.isIE11: true
  • Ext.isGecko: false
  • Ext.isIE10p: true
Actions #17

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37791

Actions #18

Updated by Lorenz Ulrich over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #19

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 of project Teams/Security/TYPO3v4-Core has been pushed to the review server.
It is available at http://review.typo3.org/40647

Actions #20

Updated by Alexander Opitz almost 9 years ago

  • Status changed from Under Review to Closed

Issue was accidentally reopened.

Actions #21

Updated by Adrien Crivelli almost 9 years ago

@Lorenz Ulrich on https://review.typo3.org/#/c/37766/, you said about generating minimized files:

I used the yuicompressor from the OS online service http://refresh-sf.com/

However if I try to reproduce that by pasting typo3/contrib/extjs/adapter/ext/ext-base-debug.js content into that service I get a very different result than you. The most obvious difference being that ext-base-debug.js clearly mentions version '3.3.1', whereas ext-base.js clearly mentions version "3.4.1.1". How would explain the difference ? Why are versions different ? How exactly did you generate those files ?

I am asking that because it seems that this patch introduced a bug where backend breaks completely in production mode, but not in debug mode.

Actions #22

Updated by Lorenz Ulrich almost 9 years ago

@ Adrien: What I did

  • I opened ext-*-debug.js from master (7.x-dev at this time) and added IE11 support.
  • Then I pasted the code to refresh-sf.com and used the YUI compressor to compress ext-*.js.
  • I did not take care of the backporting because I didn't merge the patch myself.

I don't have access to the commit that was done for 4.5. I suspect that the ExtJS version auf 4.5 and 6.2+ are different and the person who did the backport accidentially copied the files instead of building new versions.

Actions #23

Updated by Lorenz Ulrich almost 9 years ago

Update: I just could take a look at the commit for 4.5 and it clearly seems to be the case that the production files were not rebuilt based on the ExtJS 3.1 versions but just copied from the versions for 6.2+. I don't know the workflow for contributing to 4.5, but it should be easily fixable (and must be fixed).

Actions #24

Updated by Stefan Neufeind almost 9 years ago

4.5 has reached its end. There won't be updates anymore (unless for ELTS-users), sorry.

Actions #25

Updated by Lorenz Ulrich almost 9 years ago

This is about ELTS users. They got 4.5.41 with a patch that can break the backend.

Actions

Also available in: Atom PDF