Bug #56311

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

PackageFactory does not need to be initialized on regular requests

Added by Steffen Ritter over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The initialize Method of the package manage creates an instance of the PackageFactory - on99% of the requests this is not needed since the packages exist serialized in a cache.

#1

Updated by Thomas Maroschik over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Thomas Maroschik
#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28329

#3

Updated by Steffen Ritter over 8 years ago

  • Status changed from Under Review to Resolved
#4

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF