Project

General

Profile

Actions

Bug #56334

closed

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

Prevent inclusion of LogLevel due to ConfigDefault referral

Added by Steffen Ritter over 10 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Could have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
Actions #1

Updated by Stephan Großberndt about 9 years ago

typo3/sysext/core/Configuration/DefaultConfiguration.php

    'LOG' => array(
        'writerConfiguration' => array(
            \TYPO3\CMS\Core\Log\LogLevel::WARNING => array(
                \TYPO3\CMS\Core\Log\Writer\FileWriter::class => array(
                    'logFile' => 'typo3temp/logs/typo3.log'
                )
            )
        ),
        'deprecated' => array(
            'writerConfiguration' => array(
                \TYPO3\CMS\Core\Log\LogLevel::WARNING => array(
                    \TYPO3\CMS\Core\Log\Writer\FileWriter::class => array(
                        'logFile' => 'typo3conf/deprecation.log'
                    )
                )
            )
        )
    ),

Because of the LogLevels being configured as constants instead of values the class LogLevel is loaded on every bootstrap of the system even if nothing ever will be logged since config default is loaded everytime

Actions #2

Updated by Stephan Großberndt about 9 years ago

  • Category set to Performance
  • Priority changed from Should have to Could have
  • TYPO3 Version changed from 6.2 to 7
  • Complexity set to easy
Actions #3

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49228

Actions #4

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49228

Actions #5

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49228

Actions #6

Updated by Wouter Wolters over 7 years ago

  • Status changed from Under Review to New
Actions #7

Updated by Benni Mack over 7 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF