Task #56393

Epic #55070: Workpackages

Epic #54851: WP: Workspaces IRRE & MM bugfixes

Story #54853: As a user I want to correctly create, modify, preview and publish IRRE & MM related workspace changes

creation on new pages have broken permissions (perms_groupid set wrong)

Added by Peter Niederlag over 5 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-02-27
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Sprint Focus:

Description

When a regular (non admin) user creates a page in a workspace the page will not have proper permissions as the owning group(perms_groupid) is not assigned correctly.

perms_groupid (group ownership) should be based on:

  • the first(default) usergroup of the backend user (failing!) OR
  • the usergroup that is set in TSconfig (works!)

(Currently perms_userid and perms_groupid are not covered by the functional tests)


Related issues

Related to TYPO3 Core - Task #55563: Add functional test cases to DataHandler for regular workspace editing Closed 2014-02-01
Related to TYPO3 Core - Bug #58525: First usergroup from BE-user no longer applied to new pages Closed 2014-05-05
Related to TYPO3 Core - Task #54085: Replace all strcmp() calls with === Closed 2013-11-29

Associated revisions

Revision dac46664 (diff)
Added by Markus Klein over 5 years ago

[BUGFIX] Group permissions for new pages are not set

This is a regression to #54085 which accidentally converted a !strcmp()
to !==.

Resolves: #56393
Releases: 6.2
Change-Id: Ie0b2e169916e6b0ea848510e615b05d68be02199
Reviewed-on: https://review.typo3.org/29875
Reviewed-by: Nicole Cordes
Tested-by: Nicole Cordes
Reviewed-by: Loek Hilgersom
Tested-by: Loek Hilgersom
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

History

#1 Updated by Peter Niederlag over 5 years ago

  • Priority changed from Should have to Must have

#2 Updated by Peter Niederlag over 5 years ago

  • Subject changed from creating page in workspace does not have proper perms_groupid assigned to Failing to set perms_group when creating page in workspace

#3 Updated by Peter Niederlag over 5 years ago

  • Subject changed from Failing to set perms_group when creating page in workspace to Failing to set perms_groupid when creating page in workspace

#4 Updated by Peter Niederlag over 5 years ago

  • Subject changed from Failing to set perms_groupid when creating page in workspace to create pages in workspace have broken permissions (perms_groupid set wrong)

#5 Updated by Oliver Hader over 5 years ago

  • Parent task set to #54853

#6 Updated by Peter Niederlag over 5 years ago

  • Subject changed from create pages in workspace have broken permissions (perms_groupid set wrong) to creation on new pages have broken permissions (perms_groupid set wrong)

#7 Updated by Markus Klein over 5 years ago

As reported in #58525, #54085 seems to be the culprit.

#8 Updated by Markus Klein over 5 years ago

Found it, will push a patch

#9 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29875

#10 Updated by Markus Klein over 5 years ago

  • Complexity set to no-brainer
  • Is Regression changed from No to Yes

#11 Updated by Markus Klein over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF