Bug #58307

Temporary id for inline records in flexforms seems to be persisting too long.

Added by Ron Hall almost 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Could have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2014-04-29
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

While documenting another bug, I noticed something suspicious. When a FAL inline record is added to a record to in the BE it receives a temporary id number. This is expected. However, upon saving the parent record the temporary id is stored in the database rather than the number of references. If you then save the parent record a second time it will then store the number of references.

This video will illustrate the issue.

http://www.busynoggin.com/fileadmin/videos/flexform-New-ID-bug.mp4


Related issues

Related to TYPO3 Core - Feature #18957: Flexforms & IRRE doesn't work Closed 2008-06-14
Related to TYPO3 Core - Task #60654: Execute remap handling of nested children earlier Closed 2014-07-29

Associated revisions

Revision 7d181826 (diff)
Added by Oliver Hader almost 5 years ago

[BUGFIX] Invalid reference count on storing new child records in FlexForm

If creating a new parent record that contains inline child
records as part of a FlexForm configuration, the resulting
reference count is the temporary "NEW..." identifier. The
expected result is to have the number of child references
in that case as well.

Resolves: #58307
Releases: master, 6.2
Change-Id: I36a4dd06a38ad5d9f197190658b97f8a3b5fa234
Reviewed-on: http://review.typo3.org/37345
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision f5d526de (diff)
Added by Oliver Hader almost 5 years ago

[BUGFIX] Invalid reference count on storing new child records in FlexForm

If creating a new parent record that contains inline child
records as part of a FlexForm configuration, the resulting
reference count is the temporary "NEW..." identifier. The
expected result is to have the number of child references
in that case as well.

Resolves: #58307
Releases: master, 6.2
Change-Id: I36a4dd06a38ad5d9f197190658b97f8a3b5fa234
Reviewed-on: http://review.typo3.org/37346
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Fedir RYKHTIK almost 6 years ago

Looks like a hook on record's update should be executed.

#2 Updated by Oliver Hader almost 6 years ago

  • Category set to 978
  • Priority changed from -- undefined -- to Could have
  • Complexity set to hard

IRRE in FlexForms is tricky. The other way round, FlexForms in IRRE it should work...
The problem with FlexForms is, that there is no dedicated identifier for each parent-child level.

#3 Updated by Oliver Hader almost 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Oliver Hader

So, in this case it seems to be related to the remapStack that is executed too early...
The remapping process should take care of resolving all those (nested) temporary identifiers

#4 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37345

#5 Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37346

#6 Updated by Oliver Hader almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF