Feature #58332

Updating from 4.5 to 6.2 removes some be_group permissions

Added by Jost Baron over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-04-29
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:
PRC

Description

On updates from 4.5 to 6.2, the permissions for be_groups changed. In this case, the right to access the exclude fields 'imageorient' and 'imagecols' in tt_content have been removed/not added.

Each update was done version by version, going through respective latest releases of 4.5, 4.6, 4.7, 6.0 and 6.1. I cannot say in exactly which update the problem occurred, but I have experienced it in multiple cases.

When looking at old database dumps from before the update, I couldn't find permissions for the fields in the database (in table 'be_groups', field 'non_exclude_fields'), although they were editable for restricted accounts.


Related issues

Related to TYPO3 Core - Bug #44890: Several options on tt_content missing als exclude Closed 2013-01-28

History

#1 Updated by Markus Klein over 5 years ago

  • Status changed from New to Needs Feedback

This was changed with #44890 in 6.1 and 6.0.

I agree that there's total lack of documentation about this change.
At least it is documented now in the bug tracker.

Is it ok for you if I close this ticket?

#2 Updated by Jost Baron over 5 years ago

Hi Markus,

Would it be a good idea to add an upgrade wizard that adds
permissions to see the new exclude-fields when the user oder
user group is allowed to view or modify the table tt_content?

Same thing goes for access to the FAL-related tables - would
it be possible to add rights for users to access these when
updating from non-FAL to FAL versions, if they were allowed
to access the image field in tt_content before?

I see the problem that this would probably need to be added
to 6.0, 6.1 and 6.2, but it is not a real bugfix.

If it is not an option to add these upgrade wizards, please
close the issue.

#3 Updated by Alexander Opitz over 5 years ago

  • Category set to Install Tool
  • Status changed from Needs Feedback to New

#4 Updated by Mathias Schreiber about 5 years ago

  • Tracker changed from Bug to Feature

#5 Updated by Susanne Moog over 4 years ago

  • Sprint Focus set to PRC

#6 Updated by Christian Kuhn over 4 years ago

  • Status changed from New to Closed

I don't think we should still add upgrade wizards to 6.2 anymore which will reach the 'hard problem & security only' phase soonish. With 7 we have a better structure to document such stuff and we will further work on better communication for stuff like that.

So, I'd rather close this issue now as won't fix.

Also available in: Atom PDF