Bug #58768

Import from .t3d failed on Windows 7 with a lot of messages (6.1 => 6.2)

Added by Tobias Klepp over 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
-- undefined --
Assignee:
-
Category:
Import/Export (T3D)
Target version:
-
Start date:
2014-05-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I create a simple small page tree and exported this page tree as an *.t3d file. This step runs fine. If I try to import this *.t3d file in the same TYPO3, I see the complete page tree in the preview. But if I try to import it, the import failed and some messages created like

0 Possible error: pages:141 had no new id assigned to it. This indicates that the record was not added to database during import. Please check changelog!
1 Possible error: tt_content:124 had no new id assigned to it. This indicates that the record was not added to database during import. Please check changelog!
2 Error: this records is NOT created it seems! (pages:141)
3 Error: this records is NOT created it seems! (tt_content:124)
4 Error: this records is NOT created it seems! (pages:141)
5 Error: this records is NOT created it seems! (tt_content:124)

Nothing was importet. I tryed it again and again. Some times, it imported only the root page of the import. Totally crazy. I try to find out, what happens and where the error come from but have no idea. Maybe something is wrong with $this->substNEWwithIDs. The same installation on a Linux system working fine.

Has anybody an idea, how to fix this problem? Thanks very much!


Files

T3D__TYPO3_6-1.t3d (3.29 KB) T3D__TYPO3_6-1.t3d Jigal van Hemert, 2014-05-22 10:06
T3D__TYPO3_6-1.xml (28.1 KB) T3D__TYPO3_6-1.xml Jigal van Hemert, 2014-05-22 10:06

Related issues

Related to TYPO3 Core - Bug #59055: Import from .t3d failed on Windows 7 with a lot of messagesClosedMarc Bastian Heinrichs

Actions
Related to TYPO3 Core - Bug #58602: Datepicker issue on multiple datetime fields in BEClosed2014-05-07

Actions
Related to TYPO3 Core - Bug #59701: uniqid() not returning unique valuesClosedTymoteusz Motylewski2014-06-20

Actions
#1

Updated by Marc Bastian Heinrichs over 7 years ago

  • Status changed from New to Needs Feedback

In 6.1 the impexp is not complete compatible with the core (in special FAL).
This is and will be only fixed in version 6.2.
So it is strange, that everythings works with linux.

Would be great, if you could test the export and import on Win with 6.2.

#2

Updated by Tobias Klepp over 7 years ago

I testet the import also on TYPO3 6.2 and there are the same problems. Exacly the same. Additionally there are a PHP warning all the time, if I open the import form. If I selected an import file or not, makes no difference.

PHP Warning
PHP Warning: sha1_file(C:/Daten/arbeit/www/typo3_62/): failed to open stream: No such file or directory in C:\Daten\arbeit\www\typo3_62\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php line 636
#3

Updated by Marc Bastian Heinrichs over 7 years ago

Hi, thank you for testing. Could you create the same export again, but in xml format and add it to the issue, testing before that this also fails for you? Thanks in avance!

#4

Updated by Marc Bastian Heinrichs over 7 years ago

Ah, and you tested the same export from 6.1 importing in 6.2? Or you created a new export in 6.2?

#5

Updated by Jigal van Hemert over 7 years ago

Opening the import on 6.2 gives me:
PHP Warning
PHP Warning: sha1_file(D:/webserver/xampp/htdocs/): failed to open stream: No such file or directory in D:\typo3\TYPO3_Master\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php line 636

Preview of a 6.1 export in 6.2 shows:
PHP Warning
PHP Warning: fread(): Length parameter must be greater than 0 in D:\typo3\TYPO3_Master\typo3\sysext\impexp\Classes\ImportExport.php line 3017

And the messages tab reads:

0     MD5 check failed (files_fal)

After attempting the import the messages tab:

0     MD5 check failed (files_fal)
1     Error: No file found for ID 3afcdbfeb6ecfbdd0ba628696e3cc163
2     Possible error: pages:2 had no new id assigned to it. This indicates that the record was not added to database during import. Please check changelog!
3     Error: this records is NOT created it seems! (pages:2)
4     Error: this records is NOT created it seems! (pages:2)

No pages are imported but it reports:

Structure has been imported, here is the result:
Inside pagetree:

Controls:     Title:                   Size:  Message:     Result:
                Home                     1.6 K         
                 1                       1.0 K                  [sys_file_reference:1 => 4]:
                                                                Used by content elements (uid_foreign)     1
                   => sys_file:1             
                 Default Root Template   805         
                 Header text             2.7 K                  [tt_content:1 => 5]:
                                                                Caption: (imagecaption)     Field missing in database
                                                                Files (media)     Field missing in database
                                                                Items: (records)     Field missing in database
                                                                Startingpoint: (pages)     Field missing in database
                                                                Link: (image_link)     Field missing in database
                                                                Alternative Text: (altText)     Field missing in database
                                                                Title Text: (titleText)     Field missing in database
                                                                Long Description URL: (longdescURL)     Field missing in database
                                                                File collections (file_collections)     Field missing in database
                                                                File: (multimedia)     Field missing in database
                                                                Plugin Options (pi_flexform)     Field missing in database
              => 1             
               => sys_file:1             
                Page1                    1.6 K         
                Page2                    1.6 K         
                  Page3                  1.6 K         

It looks like it tries to import the file elements first to be able to refer to them in the content elements. This obviously fails because the structures changed between 6.1 and 6.2.

Attempting to Import to 6.1 I run into the issue that there is no Upload option available to me. Uploaded the .t3d to fileadmin and did the import this way.
Messages tab:

0     Possible error: pages:2 had no new id assigned to it. This indicates that the record was not added to database during import. Please check changelog!
1     Error: this records is NOT created it seems! (pages:2)
2     Error: this records is NOT created it seems! (pages:2)

Report at bottom of page:


Structure has been imported, here is the result:
Inside pagetree:

Controls:         Title:                  Size:        Message:      Result:
                  Home                    1.6 K         
                    1                     1.0 K                      [sys_file_reference:1 => 2]:
                                                                     File (uid_local)     awesome.jpg
                                                                     Used by content elements (uid_foreign)     1
                    => awesome.jpg             
                      => fileadmin/ (auto-created)             
                    Default Root Template 805                        [sys_template:1 => 2]:
                                                                     Include static (from extensions): (include_static_file)     Field missing in database
                                                                     Constants: (constants)     Field missing in database
                                                                     Setup: (config)     Field missing in database
                                                                     Description: (description)     Field missing in database
                                                                     Include Basis Template: (basedOn)     Field missing in database
                    Header text           2.7 K                      [tt_content:1 => 2]:
                                                                     Caption: (imagecaption)     Field missing in database
                                                                     Files (media)     Field missing in database
                                                                     Items: (records)     Field missing in database
                                                                     Startingpoint: (pages)     Field missing in database
                                                                     Link: (image_link)     Field missing in database
                                                                     Alternative Text: (altText)     Field missing in database
                                                                     Title Text: (titleText)     Field missing in database
                                                                     Long Description URL: (longdescURL)     Field missing in database
                                                                     File collections (file_collections)     Field missing in database
                                                                     File: (multimedia)     Field missing in database
                                                                     Plugin Options (pi_flexform)     Field missing in database
                      => 1             
                        => awesome.jpg             
                          => fileadmin/ (auto-created)             
                    Page1                 1.6 K         
                    Page2                 1.6 K         
                      Page3               1.6 K         

Outside pagetree:

Controls:         Title:                  Size:         Message:     Result:
                  awesome.jpg             838                        [sys_file:1 => 2]:
                                                                     Storage (storage)     1
                                                                     Identifier (identifier)     /user_upload/awesome.jpg
                                                                     Mime Type (mime_type)     image/jpeg
                                                                     Filename (name)     awesome.jpg
                                                                     SHA1 (sha1)     0cced1114f3be061cffd27ad5cbfcdf4cd15e171
                                                                     Size (size)     33913
                                                                     Title (title)     Field missing in database
                                                                     Description (description)     Field missing in database
                                                                     Alternative Text (alternative)     Field missing in database
                    => fileadmin/ (auto-created)             
                  fileadmin/ (auto-created) 1.0 K                    [sys_file_storage:1 => 2]:
                                                                     Folder for manipulated and temporary images etc. (processingfolder)     Field missing in database

#6

Updated by Jigal van Hemert over 7 years ago

Example exports from 6.1

#7

Updated by Marc Bastian Heinrichs over 7 years ago

  • Subject changed from Import from .t3d failed on Windows 7 with a lot of messages to Import from .t3d failed on Windows 7 with a lot of messages (6.1 => 6.2)
  • Status changed from Needs Feedback to Rejected
  • Priority changed from Must have to -- undefined --
  • Target version deleted (next-patchlevel)

As explained exports from 6.1 would not be fully compatible on importing in 6.2.

The win problems are handled in #59055. So I close this issue now.

#8

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus set to On Location Sprint
#9

Updated by Mathias Schreiber over 5 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF