Project

General

Profile

Actions

Bug #58957

closed

Frontend User Session by POST ['recs']['ts']

Added by Teamgeist Medien about 10 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2014-05-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In TYPO3 6.1 it was no problem to write inside the frontend user session by having a form an posting the values to ['recs']['ts'] in a form like this:

<form method="POST">
    <input id="default" type="submit" value="A" name="recs[ts][size]">
    <input id="big" type="submit" value="big" name="recs[ts][size]">
    <input id="bigger" type="submit" value="bigger" name="recs[ts][size]">
</form>

Since TYPO3 6.2 this does no longer work as long as there is no FE user logged in. In this case, the form is for a font resize menue that should work for all users in the frontend even if they are not logged in.
I know that the FE cookie will no longer be set as the user is not logged in, but it should be set when a user is using the form even if he is not logged in, right?

The solutions from this issue does not solve the problem for me: http://forge.typo3.org/issues/57751


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #57751: Felogin session not setClosedMarkus Klein2014-04-08

Actions
Actions #1

Updated by Michael Ganner over 9 years ago

Teamgeist Medien wrote:

In TYPO3 6.1 it was no problem to write inside the frontend user session by having a form an posting the values to ['recs']['ts'] in a form like this:

[...]

Since TYPO3 6.2 this does no longer work as long as there is no FE user logged in. In this case, the form is for a font resize menue that should work for all users in the frontend even if they are not logged in.
I know that the FE cookie will no longer be set as the user is not logged in, but it should be set when a user is using the form even if he is not logged in, right?

The solutions from this issue does not solve the problem for me: http://forge.typo3.org/issues/57751

After an update from 6.1 to 6.2 we encountered exactly the same issue. As a workaround we set [FE][maxSessionDataSize] to an empty value which is not recommended since it also disables a check that session data is stored only if a confirmed cookie is set.

Note: if [FE][maxSessionDataSize] is set to '0' we get the following Fatal error:

Fatal error: Interface 'Psr\Log\LoggerInterface' not found in /html/typo3/typo3_src-6.2.6/typo3/sysext/core/Classes/Log/Logger.php on line 24

Actions #2

Updated by Mathias Schreiber over 9 years ago

  • Target version changed from next-patchlevel to 7.1 (Cleanup)
Actions #3

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)
Actions #4

Updated by Benni Mack about 9 years ago

  • Status changed from New to Needs Feedback

Can you please recheck? we did quite some work with the session handling until 6.2.13

Actions #5

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #6

Updated by Benni Mack almost 9 years ago

  • Target version deleted (7.5)
Actions #7

Updated by Wouter Wolters over 8 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions #8

Updated by Bernhard Kraft over 8 years ago

  • Status changed from Closed to Accepted

This issue still persists.

Try something like the following TS to confirm it. If there is already a FE-User cookie set this script will work in any case - but after removing the FE-User cookie the cookie won't get set again.

page = PAGE
page.10 = TEXT
page.10.data = TSFE:fe_user|sesData|recs|ts|testing
page.10.wrap = Current value: "|"<br />

page.20 = TEXT
page.20.value (
<form action="index.php" method="POST">
<input type="text" value="" name="recs[ts][testing]" />
<input type="submit" name="submit" value="submit" />
</form>
)

A patch is being readied.

Actions #9

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47155

Actions #10

Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to New

Patch has been abandoned

Actions #11

Updated by Markus Klein over 6 years ago

  • Status changed from New to Rejected

This hasn't been fixed for such a long time and v9 does not even provide this functionality anymore (deprecated with v8).

Actions

Also available in: Atom PDF