Bug #60423

Access-Module for Non-Admins

Added by Martina Ahlswede about 7 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since TYPO3 6.0 there is no possibility to give the access module to normal users, only admins can access the access module. The change was introduced with #41229.

Is there any plan to revert it and to make the access module accessible for normal users again?

We believe that there is no better possibility to give other users access to the pages. We have about 150 installations where chief editors administrate the users through tc_beuser and give them the access to the pages they should work on. To give those chief editors full admin rights just because of the access module is no opportunity for us. There must be some kind of access module to the pages, which can be used by normal users.
Handling the access to pages through TypoScript is also no opportunity, because we need something a normal user can do, not something advanced, which needs a lot of training and is probably only for admins.

Working with different mountpoints to prevent access to pages is not the best idea, because there can be different groups, who share one mountpoint. For example in a multi-domain-installation, there is the mountpoint for the domain, but within the mountpoint three groups are acting: the chief editor, who can edit everything, the department A, responsible for all pages of department A and the department B, responsible for all pages of department B. These pages can be all over the pagetree, not strictly separated. Also we believe that the menu of the website can’t be strictly separated through user rights, because there should be the possibility to create the menu for the needs of the visitors, not as a copy of the internal structures.

What are the plans for the access to pages?


Related issues

Related to TYPO3 Core - Bug #41229: Access module got several bugsClosed2012-09-22

Actions
#1

Updated by Stefan Neufeind about 7 years ago

  • Description updated (diff)
#2

Updated by Felix Kopp almost 7 years ago

  • Status changed from New to Accepted

Approved during T3UXW14. Please solve

#3

Updated by Christian Kuhn over 3 years ago

  • Status changed from Accepted to Rejected

core will probably not solve this issue soon: admins are there to administrate user rights and similar things. with core v9, the additional concept of 'system maintainers' has been introduces, so you don't have full access about system settings as admin anymore, if that admin is not a system maintainer.
giving non-admin access to the access module is not planed.
closing this issue now.

Also available in: Atom PDF