Project

General

Profile

Actions

Bug #60860

closed

"Add Media" button in tt_content-elements fails as user

Added by Markus Volkmer over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-08-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

as a user with all possible access-rights I can no longer add media to a content-element after upgrading from 4.6 to 6.2.

way to reproduce:
- log in as user
- edit content
- open tab "images"
- click on button "Add Media"

no file browser opens (no popup-blocker or anything else)

console says:

Failed to load resource: the server responded with a status of 404 (Not Found) http://www.[DOMAIN]/typo3/typo3/sysext/backend/Resources/Public/JavaScript/FormEngine.js
Uncaught Error: Script error for: TYPO3/CMS/Backend/FormEngine
http://requirejs.org/docs/errors.html#scripterror require-6856d9551a6895234d6cabdf739abd71.js.gzip:141
RTE[data_tt_content__452__bodytext_][HTMLArea.Editor::onFrameworkReady]: Editor ready. merged-193fb2ed2e75b7c82167917430627591-e00ebd74026b724d32151409f2eb7efa.js.gzip?1407133364:795
Uncaught ReferenceError: setFormValueOpenBrowser is not defined alt_doc.php?returnUrl=%2Ftypo3%2Fsysext%2Fcms%2Flayout%2Fdb_layout.php%3Fid%3D4&edit[tt_content][45…:567

While creating a new content element adding one file works as expected - if trying to add a second file -> same issue.

As administrator everything works fine and as expected.

URL for FormEngine.js above should be:
http://www.[DOMAIN]/typo3/sysext/backend/Resources/Public/JavaScript/FormEngine.js
(with only one /typo3 in path)

Quick Workaround:
- setting a redirect for that file


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #57568: Unable to select DB Mount in sys_action "create backend user"Closed2014-04-02

Actions
Actions #1

Updated by Mathias Schreiber about 9 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

Hi markus,

is this still the case?

Actions #2

Updated by Wladimir Hofmann about 9 years ago

Hi Mathias,
I'm not marcus ;) but I can confirm, that this is still an issue.
see my screenshot attached.

TYPO3 6.2.9

Actions #3

Updated by Teamgeist Medien about 9 years ago

Just having the same problem here, when trying to create a folder for new backend users in the user-taskcenter (create new backend user action). Just getting the following JS error and no the filebrowser does not open

"Uncaught ReferenceError: setFormValueOpenBrowser is not defined"

Actions #4

Updated by schmitz no-lastname-given almost 9 years ago

I had the same issue,too.
After following actions in Install Tool it works again: Click the Button "Try to fix file and folder permissions" under "Folder structure" and "Clear all Cache" under "Important Actions".
Don't know if it fixed the problem in general or just for me.

Actions #5

Updated by Riccardo De Contardi almost 9 years ago

  • Assignee changed from Mathias Schreiber to Markus Volkmer

Markus, can you tell us if the suggestion from schmitz no-lastname-given is sufficient for you? Thank you!

Actions #6

Updated by Roman Eberle almost 9 years ago

I'm having the same problems here, with TYPO3 6.2.4 (running on a windows machine) and Firefox.
Browser error console says: "TypeError: setFormValueOpenBrowser is not a function"

InstallTool->"Clear all Cache" seems to fix the issue.

UPDATE: i cannot reproduce the fix. no idea what's happening here.

Actions #7

Updated by Alexander Opitz over 8 years ago

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.14)?

Actions #8

Updated by Urs Braem over 8 years ago

Yes, I just came here with 6.2.15. InstallTool->"Clear all Cache" wouldn't help either in my case.

Actions #9

Updated by Alexander Opitz about 8 years ago

You may need to add the rights to the user, so he has access to the FAL table.
Does this help?

Actions #10

Updated by Javier Andrade Cobo almost 8 years ago

Hi I have the same problem. Please help! I've been updating until 6.2.19 but the error still appears.
I have a local installation in MAMP and I have no problems, what is happening in the server to make the errors appear?
Thanks

Actions #11

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
  • Assignee deleted (Markus Volkmer)

I never had this issue, but it seams multiple users have an issue here. So setting this issue back to status new.

Actions #12

Updated by Luc Muller over 7 years ago

I've experienced the same issue in TYPO3 6.2.25, logged in as administrator.

Step to reproduce, in my case.

Extension tt_news, with IRRE for tt_content elements. (rg_news_ce)

- Adding a news.
- Adding a content element
- Selecting insert_plugin
- Seleting the plugin
- Using the flexform conf : select field
- Select fields update the form
- FormEngine.js is in 404 due to the /typo3/typo3/ in the file path.

If you clck in the page tree, and then reenter the news, everything works fine agains.

Problemes seems to occurs at the moment when the frame reload.

see attached screenshot

Actions #13

Updated by Stefan Terborg over 7 years ago

I can confirm this for IRRE elements in a custom extension:
  • when editing as inline element of a page everything works well,
  • when editing standalone in list module or via an extension module the FormEngine.js typo3/typo3/ error occurs.

System: TYPO3 6.2.25 after upgrade from 4.5.40

Actions #14

Updated by Luc Muller over 7 years ago

I Think this entry is not related to FAL, thus should be placed in Core Project.

Actions #15

Updated by Georg Ringer over 6 years ago

  • Status changed from New to Needs Feedback

can someone reproduce that on a 7.x or 8.x?

Actions #16

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Needs Feedback to Closed

90 days without feedback -> closing it.

If you think that this is the wrong decision or experience the issue again or have more information about how to reproduce it, please reopen it or open a new issue with a reference to this one. Thank you.

Actions

Also available in: Atom PDF