Project

General

Profile

Actions

Bug #64742

closed

first click on update-icon does not start update-dialog

Added by Bernd Wilke about 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2015-02-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

in the view 'manage extension' often the first click on an update-button does not open the popup with the history of the extension (from currently installed version to the newest version) and the button to do the update, so the spinner is shown.
after a reload of the EM a click on the update button opens the popup.

also see first part of #56978

Actions #1

Updated by Riccardo De Contardi over 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Bernd Wilke

Hi Bernd,
I tried with version 6.2.14 and I was not able to reproduce this issue; I had it with version 7 (latest master)
can you confirm?

thank you

Actions #2

Updated by Bernd Wilke over 8 years ago

I had not tested it with 7.3.1 (other Versions of 7.x I have not in use)
but I have a 6.2.14 in use and yesterday I had the described behaviour again:
in the view of installed extensions I clicked the first column to sort updateable extensions to the top. Then after a click onto an update-icon the spinner is shown - and nothing more happended. after relaunching the EM the order is the same and a click on an update icon starts the dialog with the version list between current and newest version.

Actions #3

Updated by Simon Schaufelberger over 8 years ago

have the same problem but it is hard to reproduce when exactly that is happening

Actions #4

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (next-patchlevel)
Actions #5

Updated by Nicole Cordes about 8 years ago

Multiple ajax request are started after filter process. IMHO that is the problem. Can anyone confirm?

Actions #6

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Needs Feedback to New

I also had this issue, but never looked into this, hopefully I'll remember this issue next time.

Actions #7

Updated by Nicole Cordes over 7 years ago

  • Status changed from New to Accepted
  • Assignee deleted (Bernd Wilke)
  • Target version set to 8 LTS
Actions #8

Updated by Nicole Cordes almost 7 years ago

  • Assignee set to Nicole Cordes
  • Target version changed from 8 LTS to next-patchlevel
Actions #9

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51975

Actions #10

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51975

Actions #11

Updated by Nicole Cordes almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #12

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF