Feature #65249

Hint admins a workspace has to be set up in workspace module

Added by Tymoteusz Motylewski over 6 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2015-02-24
Due date:
% Done:

100%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

It would be great for user experience if it was posssible to create new workspace directly from workspace top menu, or from workspace admin panel.


Related issues

Related to TYPO3 Core - Bug #91983: Drop 'Live workspace' tab from workspace moduleClosed2020-08-11

Actions
Has duplicate TYPO3 Core - Feature #89209: Workspaces module should display info if no workspace record is availableClosed2019-09-19

Actions
#1

Updated by Riccardo De Contardi over 5 years ago

  • Category set to Backend User Interface
#2

Updated by Benni Mack about 2 years ago

  • Category changed from Backend User Interface to Workspaces
#3

Updated by Christian Kuhn 10 months ago

  • Status changed from New to Needs Feedback

I'm not sure if this is a great idea: sys_workspace records belong to pid 0 and are admin tasks only.

They are often complex to set up in real live with stages and users and groups. An admin will spend time on pid 0 anyway to get everything right. group setups are only editable on pid 0, too.

Having some special handling for the already rather complex workspace / toolbar module does not really sound solid to me and the workspace area is already cluttered with some functionality people don't know or use very seldom.

I'd thus tend to drop this feature request.

#4

Updated by Christian Kuhn 10 months ago

  • Subject changed from create new workspaces from top menu and from workspace module to Hint admins a workspace has to be set up in workspace module
  • Status changed from Needs Feedback to Accepted

Tymoteusz argues in private chat that admins do not know that they need to set up a sys_workspace record on pid 0 to get something going.

With #91983 applied, admins calling the ws-module receive a flash message 'please switch to a workspace'. This could be adapted for admins (not users) to tell 'please add a ws-record on pid 0' if there are none.

I'll adapt the title of this issue and will set it to accepted.

#5

Updated by Christian Kuhn 10 months ago

  • Related to Bug #91983: Drop 'Live workspace' tab from workspace module added
#6

Updated by Christian Kuhn 10 months ago

  • Is duplicate of Feature #89209: Workspaces module should display info if no workspace record is available added
#7

Updated by Christian Kuhn 10 months ago

  • Is duplicate of deleted (Feature #89209: Workspaces module should display info if no workspace record is available)
#8

Updated by Christian Kuhn 10 months ago

  • Has duplicate Feature #89209: Workspaces module should display info if no workspace record is available added
#9

Updated by Gerrit Code Review 10 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65319

#10

Updated by Gerrit Code Review 10 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65319

#11

Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65302

#12

Updated by Christian Kuhn 10 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF