Bug #66307

Performance: improve trimExplode

Added by Stefan Froemken about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Performance
Target version:
-
Start date:
2015-04-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello,

trimExplode with preg_split is over 500ms faster within a loop of 100.000.

Stefan


Related issues

Related to TYPO3 Core - Task #66317: Performance: improve trimExplode 2nd tryClosedStefan Froemken2015-04-092015-04-09

Actions
#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#2

Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#3

Updated by Gerrit Code Review about 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#4

Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#5

Updated by Gerrit Code Review about 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#6

Updated by Gerrit Code Review about 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#7

Updated by Gerrit Code Review about 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#8

Updated by Gerrit Code Review about 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38513

#9

Updated by Stefan Froemken about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Nicole Cordes about 6 years ago

  • Status changed from Resolved to New
#12

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee changed from Stefan Froemken to Mathias Schreiber

how do we proceed here?

#13

Updated by Stefan Froemken almost 6 years ago

Destroy this idea. Let us create a simple PerformanceUtility.php :-) Maybe then we'll have a good possibility to add some really nice stuff.

#14

Updated by Benni Mack almost 6 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
#15

Updated by Susanne Moog almost 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#16

Updated by Benni Mack over 5 years ago

  • Target version deleted (7.5)
#17

Updated by Alexander Opitz over 5 years ago

Still something to do here after #66317 is done?

#18

Updated by Stefan Froemken over 5 years ago

  • Status changed from Needs Feedback to Closed

No answer since 8 months. So: No one like fresh and new designed performance orientated classes?

Also available in: Atom PDF