Bug #67848

Cannot update core from Install Tool

Added by René Pflamm over 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
Start date:
2015-06-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

The TYPO3 Update doesn't work becaue the version matrix for Version 7 is not complain with previous versions.

If you look at https://get.typo3.org/json all previous versions has the minor Versions defined, only the Version 7 is not defined the same way.

  6.0 {}
  6.1 {}
  6.2 {}
  7 {}

it shoud be

  6.0 {}
  6.1 {}
  6.2 {}
  7.0 {}
  7.1 {}
  7.2 {}
  7.3 {}

because the install tool core updater search for this values its got an exception: #1380905851: Minor release 7.3 not found in version matrix.


Related issues

Related to TYPO3 Core - Task #69935: Remove version matrix hack from CoreVersionService.phpClosed2015-09-18

Actions
#1

Updated by Xavier Perseguers about 6 years ago

  • Project changed from 2297 to TYPO3 Core
  • Subject changed from Version Matrix for TYPO3 7 is wrong to Cannot update core from Install Tool
  • Target version set to 7.5
  • TYPO3 Version set to 7
  • Complexity set to easy
  • Is Regression set to No
  • Sprint Focus set to Remote Sprint

to be verified (version matrix on get.typo3.org/json is actually the way we want it).

#2

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#3

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Xavier Perseguers

Is this still the case?

#4

Updated by Christian Kuhn almost 6 years ago

  • Status changed from Needs Feedback to Resolved

very likely fixed with younger 7'er versions.

#5

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF