Bug #68247

Story #69712: Further FormEngine development

group maxitems woes

Added by Christian Kuhn about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-07-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The maxitems setting for TCA group fields is somehow unclear.

tca docu states there is a default of 1 if no maxitems is set. but this only seems to fire in case there is no mm relation (?).

for "csv" relations, the maxitems=1 is active. Current behavior is that if no maxitems is set in csv relation and default 1 kicks in, the formengine still allows selecting more than one element, but datahandler throws all of them away except the first one on saving. this is a bug in formengine validation and should be fixed.

Additionally, we should find out when, where and why the maxitem default kicks in and think about if that makes sense, or if a different default should be chosen consistently (0 for "no restriction, or 9999 or similar?). This implies thought about b/w compatibility and maybe a tca migration, then.

it might be a good idea to enrich ext:styleguide with additional scenarios to nail the current and the expected situation.


Related issues

Related to TYPO3 Core - Bug #62007: Impossible to save a category with many opposite relations Rejected 2014-10-02

Associated revisions

Revision 38a1bc5d (diff)
Added by Christian Kuhn almost 3 years ago

[!!!][TASK] Improve flex and TCA handling in FormEngine

The patch adapts a series of nasty form engine areas to more solid
code. The evaluate condition code is rewritten and works much better
in flex form scenarios. The suggest wizard and svg tree are much
more solid in flex forms. The group element is rewritten
towards a better readable and easier to refactor code, dropping
method dbFileIcons(). A bunch of issues is resolved along the way.

  • TCA "default" now works in flex form section container elements
  • The "displayCond" parser is now strict and throws exceptions on
    invalid syntax and wrong referenced fields to help debugging
    faulty display conditions
  • TCA displayCond on flex fields can now be prefixed with the
    sheet name and can reference field values from neighbor sheets
  • TCA displayCond now works with flex section containers
  • TCA flex section container now throw an exception if select or
    group fields configure a MM relation - this is not supported
  • TCA ctrl requestUpdate field is dropped, onChange=reload is now allowed
    not only on flex form fields, but also on normal columns fields
  • TCA tree now works as section container element and initializes
    correctly on new records and new containers
  • GroupElement rewrite to drop dbFileIcons()
  • config option maxitems now optional for type=group and type=select
    and defaults to "many items allowed"
  • inline now works in "fancy" flex situations with "new" records
    by handing the final dataStructureIdentifier around
  • FormEngine no longer loads extJS

Change-Id: Id1d081627529cc1502bb198389e5bd69372815cd
Resolves: #78899
Resolves: #72307
Resolves: #75646
Resolves: #76637
Resolves: #72106
Resolves: #78824
Resolves: #76793
Resolves: #68247
Resolves: #69715
Related: #78460
Related: #67198
Related: #72294
Releases: master
Reviewed-on: https://review.typo3.org/50879
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Christian Kuhn about 4 years ago

  • Description updated (diff)

#2 Updated by Christian Kuhn almost 4 years ago

  • Category set to FormEngine aka TCEforms

#3 Updated by Frank Naegler almost 4 years ago

  • Status changed from New to Needs Feedback

I can't reproduce the problem.
Can you provide example(s) in EXT:styleguide?

#4 Updated by Alexander Opitz almost 4 years ago

  • PHP Version deleted (7.0)

It seems this haven't todo with PHP version, so unsetting.

#5 Updated by Alexander Opitz over 3 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (7 LTS)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#6 Updated by Christian Kuhn over 3 years ago

  • Parent task set to #69712

#7 Updated by Christian Kuhn over 3 years ago

  • Status changed from Closed to New

I think this is still the case. at least the whole maxitem area in combination with the different renderTypes is a bit weird and could be simplified.

I re-opened the issues and set #69712 as parent. That should make it more obvious that this issue is still an area to improve / adapt TCA syntax, simplify and document in a better way.

#8 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 39 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#9 Updated by Gerrit Code Review almost 3 years ago

Patch set 40 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#10 Updated by Gerrit Code Review almost 3 years ago

Patch set 41 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#11 Updated by Gerrit Code Review almost 3 years ago

Patch set 42 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#12 Updated by Gerrit Code Review almost 3 years ago

Patch set 43 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#13 Updated by Gerrit Code Review almost 3 years ago

Patch set 44 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#14 Updated by Gerrit Code Review almost 3 years ago

Patch set 45 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#15 Updated by Gerrit Code Review almost 3 years ago

Patch set 46 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#16 Updated by Gerrit Code Review almost 3 years ago

Patch set 47 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#17 Updated by Gerrit Code Review almost 3 years ago

Patch set 48 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#18 Updated by Christian Kuhn almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF