Bug #68272

missing label [Translate to LANGUAGE] inside RTE

Added by Riccardo De Contardi over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2015-07-17
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Test done with 7.4 (latest master)

When I translate a CE like "Text" from default language to another (e.g. English), the title it is prepended with the string "[translate to English]", while inside the bodytext, only "[]" is prepended,as if the label were missing


Related issues

Related to TYPO3 Core - Bug #71416: Translate prefix must be not added to bodytext of cType form Closed 2015-11-08

History

#1 Updated by Riccardo De Contardi about 5 years ago

on "Text with images", it works; it seems to affect only "Text Only" elements (tried with 7.5.0-dev latest master)

#2 Updated by Riccardo De Contardi almost 5 years ago

  • PHP Version changed from 5.5 to 5.6

I was wrong. The problem is still present on 7.6-dev (latest master) and affects also the text with image.

Steps to reproduce:

1) create a new content element text or text with image
2) DO NOT set an headline
3) type something in the RTE
4) translate it

RESULT: the text inside the RTE IS prepended with [Translate to English:]

5) create a new content element text or text with image
6) set an headline
7) type something in the RTE
8) translate it

RESULT: the headline is prepended with [Translate to English:] but the text inside the RTE is not: it is prepended with []

#3 Updated by Riccardo De Contardi almost 5 years ago

I can confirm it with the latest master, and with Fluid Styled Content, too

#4 Updated by Peter Linzenkirchner over 4 years ago

I can confirm it too:
current master (8.1.0-dev)
for all multi line text fields including the file meta data (tt_content|bodytext, sys_file_reference|description)

#5 Updated by Georg Ringer about 4 years ago

  • Status changed from New to Closed

i am closing this as duplicate in favor of #77506

Also available in: Atom PDF