Bug #68517

FlexForm does not change while switching to another Plugin

Added by Stefan Froemken almost 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-07-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

when I change from Plugin1 to Plugin2 in my Content-Record the FlexForm was not changed. Further the message that "the form fields will change now" does not appear.
After changing the plugin I have to save first now.

Stefan

#1

Updated by Daniel Goerz almost 6 years ago

I cannot reproduce this. Does this error still exist?

#2

Updated by Stefan Froemken almost 6 years ago

I have this problem on current master from 27.07.2015 08:08.
Tested in FF and Chrome.
No JavaScript problems logged in console.log.

#3

Updated by Frans Saris almost 6 years ago

Stefan this worked on 6.2 and 7.3?

#4

Updated by Frans Saris almost 6 years ago

  • Status changed from New to Needs Feedback
#5

Updated by Stefan Froemken almost 6 years ago

It worked since years. I just confirm it on TYPO3 6.2. I don't have a TYPO3 7.3 installation here.

#6

Updated by Markus Klein almost 6 years ago

  • Status changed from Needs Feedback to New
#7

Updated by Andreas Wolf almost 6 years ago

  • Status changed from New to Rejected

Works for me on current master. As others also reported that it works, I’ll close this.

@Stefan ping me on Slack if you can reproduce it again, then we can sort it out. :-)

#8

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from Rejected to New

this is reproducable.

How I do it: I have in current master installed ext:news and ext:cal. Then a plugin is created on any page, and the select field with the available plugins contains News and Calendar. Selecting any value does not reload the form, so the dedicated flexforms are not shown.

#9

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from New to Rejected

Obviously it is only me. We tried this now with four people. Sorry to say this, there must be some weird configuration issue, and maybe the moon phase plays a role as well. Lets wait for other reports to come it, that help shine a light on this. I will close the issue until then.

#10

Updated by Markus Klein almost 6 years ago

  • Sprint Focus deleted (Stabilization Sprint)

After hours of tracing we found out that a garbled TCA is the culprit.
Caused by the bootstrap_package. Pull request https://github.com/benjaminkott/bootstrap_package/pull/210

#11

Updated by Markus Klein almost 6 years ago

  • Target version deleted (7.4 (Backend))
#12

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from Rejected to Resolved

so no core error, only a missing $GLOBALS in third party extension. Thanks for this catch.

#13

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF