Bug #69310

Attempt to reset workspace failed

Added by Albrecht Köhnlein over 5 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2015-08-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When publishing a workspace, I often see this message:

[newlog()] Attempt to reset workspace for record failed because you do not have edit access

There's no information about table and record uid. So I cannot give more information at the moment.


Files

Bildschirmfoto 2015-08-24 um 12.14.53.png (13.9 KB) Bildschirmfoto 2015-08-24 um 12.14.53.png Albrecht Köhnlein, 2015-08-25 14:27
log.png (126 KB) log.png Albrecht Köhnlein, 2015-11-13 08:59

Related issues

Related to TYPO3 Core - Bug #77758: Deleting a workspace spams logClosed2016-09-01

Actions
Related to TYPO3 Core - Bug #91881: Massive load when deleting sys_workspace record on pid 0Closed2020-07-28

Actions
Related to TYPO3 Core - Bug #61719: Warnings on flushing whole workspace with localizationsClosedOliver Hader2014-09-18

Actions
#1

Updated by Albrecht Köhnlein over 5 years ago

Sorry, it's not when "publishing" a workspace, but when a workspace is deleted.

(Is there any way for me to edit the text above?)

#2

Updated by Oliver Hader about 5 years ago

  • Status changed from New to Needs Feedback

What kind of content are you dealing with? Structured, 1:n, m:n, flexforms?
I think "deleting" in this regard means "discarding", right? Did you discard single elements or the the whole workspace?

#3

Updated by Albrecht Köhnlein about 5 years ago

The errors occured, when the record from "sys_workspace" was deleted. See log.png

And I cannot tell, which kind of content/relation lead to the problem. The log does not give any information about the table name. And I didn't see the errors by myself, but was told by an editor.

#4

Updated by Alexander Opitz almost 5 years ago

  • Status changed from Needs Feedback to New
  • Assignee set to Oliver Hader
#5

Updated by Oliver Hader 5 months ago

  • Assignee deleted (Oliver Hader)
#6

Updated by Christian Kuhn 4 months ago

  • Related to Bug #91881: Massive load when deleting sys_workspace record on pid 0 added
#7

Updated by Christian Kuhn 4 months ago

  • Related to Bug #61719: Warnings on flushing whole workspace with localizations added
#8

Updated by Christian Kuhn 4 months ago

Tried to reproduce this one.

Note we're talking about deleting a sys_workspace record from pid 0 here. This should delete all records in all tables assigned to the workspace.

I ran into the error message "Attempt to reset workspace for record failed: No record" that is raised before quite a lot and fixed that with #61719. The patch also improves the error message to be more useful.

Additionally, #91881 is much more severe and needs immediate fix first. The patch comes with some functional tests to verify workspace records of the to-delete sys_workspace are actually deleted.

For the issue itself (raising error "Attempt to reset workspace for record failed because you do not have edit access"), I'm unable to reproduce directly. Deleting a sys_workspace record requires admin access rights anyway since it is on pid 0, so some access rights problem is unlikely since that is correctly handled in DataHandler.

I suggest to change the error message to contain the table and id it is handling as a patch for this issue. This will simplify debugging so we can handle a fresh issue with clean how-to-reproduce, in case the issue itself persists.

#9

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65135

#10

Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65135

#11

Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65135

#12

Updated by Christian Kuhn 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Gerrit Code Review 4 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65105

#14

Updated by Christian Kuhn 4 months ago

  • Status changed from Under Review to Resolved
#15

Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF