Project

General

Profile

Actions

Bug #69906

closed

Translated categories can not be (re-)assigned to original record in listview

Added by Esben Leonhard over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Categorization API
Start date:
2015-09-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The select field, l10n_parent, in a translated category record contains only one (if any) record due to wrong TCA configuration.

Line 73 in \typo3_src-6.2.15\typo3\sysext\core\Configuration\TCA\sys_category.php:

'foreign_table_where' => 'AND sys_category.uid=###REC_FIELD_l10n_parent### AND sys_category.sys_language_uid IN (-1,0)'

Might have been:

'foreign_table_where' => 'AND sys_category.parent=###REC_FIELD_parent### AND sys_category.sys_language_uid IN (-1,0)'


Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Bug #92863: TCA change for sys_file_reference l10n_parent kills performanceClosed2020-11-17

Actions
Related to TYPO3 Core - Bug #92873: Regression: Image on translated page not shown anymoreNewTymoteusz Motylewski2020-11-19

Actions
Actions #1

Updated by Riccardo De Contardi over 8 years ago

  • Target version changed from 6.2.16 to Candidate for patchlevel
Actions #2

Updated by Riccardo De Contardi over 4 years ago

I think I've found a way to reproduce this issue on latest master (by the way: the code mentioned in the description is still present):

Prerequisites

1. TYPO3 with more than one language (e.g Italian (Default) and English (ID=1)
2. A page with more that one language

Test

1. On a page (that has a translation) create a category "TEST" (use List view)
2. Translate "TEST" in the other language (call it for example "TEST ENG")
3. in List view > Edit "TEST ENG" > go to "Languages" tab

- the dropdown Transl.Orig [l10n_parent] has two entries:

[0]
[x] TEST

where [x] is the ID of the "TEST" category

4. Select the empty entry ([0]), save and close
5. Edit again "TEST ENG"
6. Go to "Languages" tab and click on the Transl.Orig [l10n_parent] dropdown

Result:

The dropdown contains only the "[0]" entry, so it is not possible to reassign the category to the original "TEST"

Note

I don't know if this is "by design": in fact, what values should the dropdown show? It should be every category in the default language

Actions #3

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66221

Actions #4

Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66221

Actions #5

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66293

Actions #6

Updated by Christian Kuhn over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Markus Klein over 3 years ago

  • Related to Bug #92863: TCA change for sys_file_reference l10n_parent kills performance added
Actions #8

Updated by Oliver Hader over 3 years ago

  • Related to Bug #92873: Regression: Image on translated page not shown anymore added
Actions #9

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF