Bug #70033

Story #69617: FormEngine bugs

type select fields should not show icons below by default

Added by Georg Ringer about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2015-09-23
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

IMO it is not useful to show the icons always, e.g. with tt_content and l18n_parent, this just doesn't add more value to the editor.

Associated revisions

Revision e74c8481 (diff)
Added by Nicole Cordes about 4 years ago

[!!!][FEATURE] Add showIconTable option for selectSingle fields

This patch introduces a new option "showIconTable" for select fields
with renderType "selectSingle". Furthermore it removes the functionality
for old options "noIconsBelowSelect" "foreign_table_loadIcons" and
"suppress_icons".

The advantages is to have only one option which controls the visibility
of the icon table instead of having multiple ways.

A migration wizards sets the new property according to the old behavior
and generates deprecation messages for the tables and fields using old
options.

Core TCA definitions are adjusted to use the new option. The language
fields are changed to show the icon table by default.

Resolves: #70033
Releases: master
Change-Id: I611cd50233255bbe35a371efac1f59dc086aa73e
Reviewed-on: http://review.typo3.org/43933
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Christian Kuhn about 4 years ago

Well, this is a side effect since the data processing now finds more icons by default than before. The fact that more icons are resolved should be kept since it is helpful at other places.

I'm unsure on how to change current behavior in a sane way. There is the option "noIconsBelowSelect" than can be set to 1 to suppress this table display:

a) The easiest change is to just set this in TCA for those fields where we do NOT want the icons.

b) Another option is to interpret a missing "noIconsBelowSelect" as TRUE, this would change the default of this config option and it may have the side effect that lots of those icon phalanxes disappear since the option now needs to be explicitly set to FALSE to show the icon table again. This also has the effect that "noIconBelowSelect = FALSE" is hard to read and a double negative option then.

c) Another option would be to drop "noIconBelowSelect" altogether and either remove this icon table foo as well, or implement a new option "showIconTable" or similar that must be set to TRUE. In this case no 1:1 migration would be possible. And we may have a chat with the one or the other UX person to find out what they think about the icon stuff in the first place.

How to proceed?

#2 Updated by Christian Kuhn about 4 years ago

After discussion with Georg it seems the best option is c):

  • Create a new option "showRecordIcons" or "showItemIconsAsClickField" or similar that triggers rendering of this table. Default is false (no table shown).
  • Drop "noIconsBelowSelect"
  • Add TcaMigration that drops "noIconBelowSelect" and writes deprecation
  • Add a breaking.rst for the removal, add feature.rst for new option
  • Add new option in core where we want it (eg. tt_content types).

Reasoning:

  • The vast majority of select drop downs does not want to have these icons, so it makes much more sense to explicitly enable it.
  • The negative "no*" is not great and can be swapped along the way.
  • The new option is easy to understand and there is no additional magic involved.

#3 Updated by Markus Klein about 4 years ago

Full ack!

#4 Updated by Markus Klein about 4 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to 7 LTS

#5 Updated by Frank Naegler about 4 years ago

opt for solution c)

#6 Updated by Markus Klein about 4 years ago

  • Sprint Focus set to Remote Sprint

#7 Updated by Nicole Cordes about 4 years ago

  • Assignee set to Nicole Cordes

#8 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#9 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#10 Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#11 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#12 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#13 Updated by Gerrit Code Review about 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#14 Updated by Gerrit Code Review about 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#15 Updated by Gerrit Code Review about 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#16 Updated by Gerrit Code Review about 4 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43933

#17 Updated by Nicole Cordes about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#18 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF