Bug #70146

Story #69617: FormEngine bugs

Input placeholder record traversal is broken

Added by Sebastian Michaelsen about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-09-28
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have a TCA field like this:

        'seats' => [
            'label' => $lll . '.seats',
            'config' => [
                'type' => 'input',
                'size' => 4,
                'placeholder' => '__row|tour|default_seats'
            ],
        ],

Which is broken since the FormEngine refactoring (b524fc86). It works on the commit before, but after the refactoring I get this:


http://shots.michaelsen.io/KJVg

tripshop.tar.bz (8.3 KB) Morton Jonuschat, 2015-10-31 16:30


Related issues

Related to TYPO3 Core - Bug #70297: Placeholder config with default value of related record field fails Closed 2015-10-02

Associated revisions

Revision 13177fa0 (diff)
Added by Morton Jonuschat about 4 years ago

[TASK] FormEngine: Replace placeholder resolving with a data provider

Resolving of placeholder for field types text and input has been moved
from the element rendering into the form data providers. The data
provider approach allows reuse of existing providers and data groups and
reduces the amount of database queries by having access to previously
parsed data.

Resolves: #70370
Resolves: #70146
Resolves: #70297
Releases: master
Change-Id: I05fa2c6d3237e65627cae74811d1a9202e3ac0c8
Reviewed-on: http://review.typo3.org/43748
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision beda47e8 (diff)
Added by Morton Jonuschat almost 4 years ago

[BUGFIX] FormEngine: Fix placeholder traversal for select type relations

When creating a new record that resolves the placeholder from a related
record via a select type field empty values get filtered out. Otherwise
an exception gets raised as 0 is not a positive integer.

Resolves: #70146
Releases: master
Change-Id: I2e49380afed40df160db7e911d3128e6664f33d0
Reviewed-on: https://review.typo3.org/44440
Reviewed-by: Sebastian Fischer <>
Tested-by: Sebastian Fischer <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Morton Jonuschat about 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Morton Jonuschat

#2 Updated by Morton Jonuschat about 4 years ago

  • Parent task set to #69617

#3 Updated by Gerrit Code Review about 4 years ago

  • Status changed from In Progress to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43748

#4 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43748

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43748

#6 Updated by Morton Jonuschat about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Sebastian Michaelsen about 4 years ago

  • Status changed from Resolved to New

Sorry, not solved for me. The field configuration now is:

'seats' => [
    'label' => $lll . '.seats',
    'config' => [
        'type' => 'input',
        'size' => 4,
        'placeholder' => '__row|tour|default_seats',
        'eval' => 'null',
        'mode' => 'useOrOverridePlaceholder'
    ],
],

And I get the following exception:


http://shots.michaelsen.io/KWLU

For me it looks like the problem occurs when there is no related record configured. In my case the record has no tour. That's why it ends up trying to load the tour with uid 0. When there's no tour associated the placeholder should be blank.

#8 Updated by Wouter Wolters almost 4 years ago

  • Status changed from New to Needs Feedback

Is this resolved now?

#9 Updated by Christian Kuhn almost 4 years ago

  • Target version set to 7 LTS

#10 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44440

#11 Updated by Morton Jonuschat almost 4 years ago

Added extension for verification

#12 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44440

#13 Updated by Morton Jonuschat almost 4 years ago

  • Status changed from Under Review to Resolved

#14 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF