Bug #70951

Story #69617: FormEngine bugs

PHP Warning while calling renderForeignRecordHeader

Added by Stefan Froemken over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-10-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

in case of restructuring the TCA all values for selct-fields are of type array now. I know, we can't revert it, but we have to update the related code.

Example:

InlineRecordContainer::renderForeignRecordHeader() at line 358 we have following:

$valueParts = GeneralUtility::trimExplode('|', $rec[$titleCol]);

In my case the field was declared as type "inline", so $rec[$titleCol] returns an array now, which results in following warning:

PHP Warning: explode() expects parameter 2 to be string, array given

Stefan


Related issues

Related to TYPO3 Core - Bug #71002: Label of foreign table was not shown in case of irre and foreign_labelClosedStefan Froemken2015-10-25

Actions
#1

Updated by Oliver Hader over 5 years ago

Stefan, can you please provide a patch for that and push it to Gerrit? It seems that you already had changed these things on your side, so why not just pushing it to the accordant place at review.typo3.org? Thx! :)

#2

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44254

#3

Updated by Christian Kuhn over 5 years ago

  • Parent task set to #69617
#4

Updated by Stefan Froemken over 5 years ago

Hi Olli,

I only have mentioned one example and I have titled it as "Example". How many problems of this case we have in TYPO3 Core? 50? 100? Since the refactoring I just have found two of them and solved one. With this ticket I wanted to start a task to search for further problems of this type. So IMO this ticket is not solveable with a 3 letter change.

So what's next? Should I/We/Community create a new patch for each kind of this problem? If yes, than you're right and I can solve and push a solution within seconds.

#5

Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44254

#6

Updated by Christian Kuhn over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

was resolved with the solution from the related issue.

#7

Updated by Gerrit Code Review over 5 years ago

  • Status changed from Resolved to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44254

#8

Updated by Mathias Schreiber over 5 years ago

  • Status changed from Under Review to Resolved
#9

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF