Bug #71584

Autosuggest for a page-title only works while not all of the title is entered

Added by Stefan Neufeind over 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
Start date:
2015-11-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Livesearch: I have an "Examplepage". When typing the first characters autosuggest correctly reports the match. As soon as I enter the last letter no entries are found anymore.

(PS: Björn Jacob mentioned he can confirm the problem.)


Files

Schermata 2015-12-05 alle 23.26.58.png (130 KB) Schermata 2015-12-05 alle 23.26.58.png Riccardo De Contardi, 2015-12-05 23:29
#1

Updated by Riccardo De Contardi over 6 years ago

  • Target version set to Candidate for patchlevel
#2

Updated by Georg Ringer over 6 years ago

  • Description updated (diff)
#3

Updated by Georg Ringer over 6 years ago

  • Status changed from New to Accepted
#4

Updated by Jigal van Hemert over 6 years ago

It happens in various situations, unfortunately I couldn't find the exact conditions to replicate this with certainty. The JSON data that is returned from the backend is correct. It seems to be a problem in the JS. Normally a message is shown if there are no results, but in this case the JSON contains one or more results and yet there is nothing shown in the results.

#5

Updated by Daniel Goerz over 6 years ago

What autosuggest are we talking about?

#6

Updated by Stefan Neufeind over 6 years ago

Upper-right corner. Search across all TYPO3-content.

#7

Updated by Riccardo De Contardi over 6 years ago

Confirmed with 7.6.1-dev (latest master) see attached screenshot

#8

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45177

#9

Updated by Michael Oehlhof over 6 years ago

  • Assignee set to Michael Oehlhof
  • Target version changed from Candidate for patchlevel to 7.6.1
#10

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45177

#11

Updated by Michael Oehlhof over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF