Bug #72547

Moving orig tt_content records does not move translated records

Added by Stefan Froemken over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2016-01-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

I the new localize wizward you told the customer following:
"Translating content will create a direct connection between the original language and the language you translate to."

When I move a tt_content record with help of drag&drop in columns-view the translated record will not be move to the same col.

Stefan


Related issues

Related to TYPO3 Core - Task #66540: Avoid having content jump up and down when dragging elementsClosedJo Hasenau2015-04-22

Actions
Related to TYPO3 Core - Feature #74179: Add Copy On Drop for the page module (via CTRL Key)ClosedJo Hasenau2016-03-04

Actions
Related to TYPO3 Core - Bug #21161: Problem with moved translated content elements (wrong column)AcceptedJo Hasenau2010-08-10

Actions
#1

Updated by Tobias H. over 5 years ago

I can confirm. I wonder why we do have Drag&Drop when it is not working with multilanguage websites? I think it is a bug and should be implemented in 7 LTS.

#2

Updated by Tobias H. over 5 years ago

New findings: The element is moved, but the page module can not display it correctly. So a page reload will show the translated record in the new position. I did not try it with moving to another colpos.

#3

Updated by David Richter over 5 years ago

  • Target version changed from 8.0 to 7.6.3

T3version 7.6.2


Unfortunately I can't confirm the new findings of you, Tobias.
Even clearing the caches and hard-reloading the backend doesn't move the record for me.

What we found out / Behaviour:
If you click "translate" in the translation wizard, instead of "copy" you have no possibility of moving, neither simply adding any new content in the translated language after that.
Additionally the translated record won't be moved when the original record is moved to another column, as Stefan and Tobias said before.

In my opinion it's definitely a serious bug which makes translating and moving after that impossible. The editors always have to delete the records, move it and localize it again.

The only workaround I've found is:
  • translate the record
  • set the column of the translated record manually in the "column" dropdown of the record settings.

PS we've also tried deactivating EXT:gridelements to eliminate this as a possible cause, changed nothing so it seems very likely to be a core bug.

#4

Updated by Markus Sommer over 5 years ago

  • Priority changed from Should have to Must have
  • TYPO3 Version changed from 8 to 7
#5

Updated by Jo Hasenau over 5 years ago

When using "translate" in the translation wizard, it is by definition that you can NOT move translations separated from their translation parent in the default language.
If you need to do that, you MUST use the other translation concept which is not connecting default language and translated elements.

This has been treated kind of "loosely" in earlier versions of TYPO3 but CMS 7 now clearly distinguishes between these concepts.
If you have a mixed content, you will see a warning messsage, telling you about content inconsistencies.

So basically this ticket will be about moving translations TOGETHER with their default language parents, which is actually working but not directly visible when using D&D.
The pragmatic approach would be to add a reload action to onDrop as it is already proposed for the new copy on drop feature.
The sophisticated approach would be to connect translated children to their respective parents in the language view and have them switch positions accordingly.

Any opinions?

#6

Updated by Jo Hasenau over 5 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Jo Hasenau
#7

Updated by David Richter over 5 years ago

Hi Jo,

thanks for your feedback to this issue.

I agree, the two-way concept of the translations is correct in this form.
But we do have two obscurities/questions according to your answer:
  1. when you want to translate all contents mainly, but then want to add one additional content element only for the translated language, this isn't possible. Is there any way to achieve this?
  2. We can't confirm that the translated records are moved in a "hidden" way when the original content is moved to another column. Even after a reload the translated CE isn't moved in the correct column where the original one was placed. This was tested on three different, both local and remote, server installations.

Is there anything that we can or have to configure?

#8

Updated by Alexander Opitz about 5 years ago

  • Status changed from Needs Feedback to New
  • Target version changed from 7.6.3 to Candidate for patchlevel
#9

Updated by Kevin Lieser almost 4 years ago

Any news on this bug?

#10

Updated by Stefan Froemken over 3 years ago

I think we can close this issue now, since we have the new translation handling in TYPO3.

#11

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Closed
  • Assignee deleted (Jo Hasenau)
  • Target version deleted (Candidate for patchlevel)

@Stefan I close this one for now, as you requested. Feel free to reopen it (or ping me and I'll do) if the issue comes out again or there is still work left to do. Thanks.

Also available in: Atom PDF