Bug #72657

Paste into t3editor does not work

Added by Daniel Wagner over 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
t3editor
Target version:
-
Start date:
2016-01-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

copy something and pasting it into typoscript templates which use t3editor fails to often.
this problem already existed in 6.2 but there it was possible to deactivate t3editor to circumvent the problem.

TypeError: pos is null
removeRange() undo.js:367
UndoHistory.prototype.applyChain() undo.js:375
UndoHistory.prototype.updateTo() undo.js:182
UndoHistory.prototype.pushChains() undo.js:117
UndoHistory.prototype.push() undo.js:111
Editor.prototype.replaceRange() editor.js:780
Editor.prototype.replaceSelection() editor.js:698
Editor.prototype.reroutePasteEvent() editor.js:768


Related issues

Related to TYPO3 Core - Task #28853: Upgrade CodeMirror to 3.0Closed2011-08-08

Actions
Related to TYPO3 Core - Feature #81901: Refactor t3editorClosedAndreas Fernandez2017-07-17

Actions
Has duplicate TYPO3 Core - Bug #53213: TypoScript Editor copy&paste BugsClosed2013-10-30

Actions
Has duplicate TYPO3 Core - Bug #82677: Can't paste into empty TypoScript editor window (in Firefox)Rejected2017-10-04

Actions
#1

Updated by Andreas Fernandez over 6 years ago

  • Status changed from New to Needs Feedback

I've tested it with Chrome on OS X 10.11 and it worked for me. Can you please tell which browser you use and what exactly you want to paste? It would be cool if you could provide a text snippet for testing.

#2

Updated by Daniel Wagner over 6 years ago

I am using Firefox 43.0.4 on Ubuntu,
pasted a simple comment: ## POSTGRES

sometimes it works and sometime not :/

#3

Updated by Andreas Fernandez over 6 years ago

I tested it with Firefox 45.0a2 and can't confirm the issue :(

#4

Updated by Daniel Wagner over 6 years ago

Same result but other cause by Firefox 43.0.4 on Windows: (in Chrome not reproducable, too)

TypeError: next is undefined
UndoHistory.prototype.shadowChain() undo.js:342
UndoHistory.prototype.updateTo() undo.js:181
UndoHistory.prototype.commit() undo.js:164
Editor.prototype.replaceSelection() editor.js:692
Editor.prototype.reroutePasteEvent()

A second try delivers the same cause as above mentioned:
TypeError: pos is null
removeRange() undo.js:367
UndoHistory.prototype.applyChain() undo.js:375
UndoHistory.prototype.updateTo() undo.js:182
UndoHistory.prototype.pushChains() undo.js:117
UndoHistory.prototype.push() undo.js:111
Editor.prototype.replaceRange() editor.js:780
Editor.prototype.replaceSelection() editor.js:698
Editor.prototype.reroutePasteEvent() editor.js:768

#5

Updated by Felix Nagel over 6 years ago

Tested in TYPO3 7.6.2 and Firefox 43.0.4 stable -- seems to work as expected.

#6

Updated by Daniel Wagner over 6 years ago

Tested TYPO3 7.6.2 with Firefox 44.0.2 stable on Windows 8.1 and
can confirm a similar problem: only the first line get's inserted.
The cause: NotFoundError: Node was not found undo.js:383.

#7

Updated by Riccardo De Contardi about 6 years ago

  • Status changed from Needs Feedback to New

I can confirm this issue with the latest master 8.2-dev and Firefox 46.0.1 on MACOSX - the error is the same: NotFoundError: Node was not found undo.js:383. and only the first line is inserted but only for the first time: if you do again cmd+a, cmd+v again, all lines are inserted.

#8

Updated by Riccardo De Contardi almost 6 years ago

The problem still occurs with 8.3-dev and Firefox 48

#9

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53413

#10

Updated by Andreas Fernandez almost 5 years ago

#11

Updated by Andreas Fernandez over 4 years ago

  • Status changed from Under Review to Rejected

Can be only fixed with upgrading CodeMirror to an unknown version. The issue is fixed since #81901 for upcoming v9.

#12

Updated by Andreas Fernandez over 4 years ago

  • Has duplicate Bug #82677: Can't paste into empty TypoScript editor window (in Firefox) added

Also available in: Atom PDF