Project

General

Profile

Actions

Bug #53213

closed

TypoScript Editor copy&paste Bugs

Added by Gernot Ploiner over 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
t3editor
Target version:
Start date:
2013-10-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you copy&paste TypoScript code into a new template, some errors appears.
Try the following to reproduce it:

Create a new TypoScript Extension-Template and open the Setup-Field for the first time.
Then copy & paste any TypoScript-Code into it. It wont work.
Press Enter. Then paste again. Only the first Line of the Clipboard is inserted an there is a mystery with Linenumbers (see Screen 1). There are blank lines and the lines are vertically misplaced.

Try to delete the Code. It is not possible to delete the empty Line 1.
Paste again: Now it works, but the Linenumbers are broken again (see Sceen 2).

Tested in TYPO3 6.1.5 and Firefox 24 and 25.

In Chrome 30 copy&paste works, but the Linenumbers are also broken (see Screnn 3).

The Problem is also well-known in all other TYPO3 Versions.


Files

Screen1_firefox.gif (9.04 KB) Screen1_firefox.gif Firefox after first ENTER and paste a few lines (only the first line was inserted) Gernot Ploiner, 2013-10-30 06:59
Screen2_firefox.gif (8.32 KB) Screen2_firefox.gif Firefox after more ENTERs and paste. Linenumbers are wrong. Gernot Ploiner, 2013-10-30 06:59
Screen3_chrome.gif (8.13 KB) Screen3_chrome.gif Chrome after first paste. Linenumbers are wrong. Gernot Ploiner, 2013-10-30 06:59

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Task #28853: Upgrade CodeMirror to 3.0Closed2011-08-08

Actions
Is duplicate of TYPO3 Core - Bug #72657: Paste into t3editor does not workRejected2016-01-12

Actions
Has duplicate TYPO3 Core - Bug #82677: Can't paste into empty TypoScript editor window (in Firefox)Rejected2017-10-04

Actions
Actions #1

Updated by Stefan Neufeind over 10 years ago

I doubt this is easily fixable. Our editor (codemirror) is currently still a very ancient version. Even the author of the editor kindly asks us to please move to a more current version :-)

Actions #2

Updated by Mathias Schreiber about 9 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
Actions #3

Updated by Susanne Moog over 8 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #4

Updated by Riccardo De Contardi over 8 years ago

  • Category set to t3editor
Actions #5

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #6

Updated by Riccardo De Contardi over 8 years ago

  • Target version changed from 7 LTS to 8 LTS

Will be fixed by updating to a new version of codemirror

Actions #7

Updated by Daniel Goerz almost 7 years ago

  • Status changed from New to Closed

Closed as a duplicate of #72657. Please continue the discussion there.

Actions #8

Updated by Andreas Kienast over 6 years ago

  • Has duplicate Bug #82677: Can't paste into empty TypoScript editor window (in Firefox) added
Actions

Also available in: Atom PDF