Bug #72834

sys_language_mode = content_fallback ; 1,0 is not working with Extbase

Added by Eric Chavaillaz over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2016-01-20
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

For example, "sys_language_mode = content_fallback ; 1,0" is not working with Extbase (in reality just the part after the ";").
The fallback is always taken from the default language (uid 0).

If I test with "normal" content elements, it is working.

Thanks


Related issues

Related to TYPO3 Core - Bug #63031: Weird Translation behaviour in extbase Closed 2014-11-17
Related to TYPO3 Core - Bug #17354: fallback for menus. "content_fallback;1,0" has no affect for page records (e.g. menu) Closed 2007-07-22

History

#1 Updated by Tobias H. over 3 years ago

Hi,

no one cares. See here: https://forge.typo3.org/issues/63031

content_fallback or hideNonTranslated will not work with extbase. You have to use language mode "strict".

#2 Updated by Benni Mack about 3 years ago

  • Target version changed from 6.2.18 to Candidate for patchlevel

#3 Updated by Markus Klein about 3 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)
content_fallback ; 1,0 

this in general does NOT work in TYPO3 anymore since quite a long time now (unfortunately).
So this issue is not extbase specific.

Once the remaining Core is able to handle real fallback chains (#17354) this can be tackled.

Also available in: Atom PDF