Bug #75721

Updating extension list fails in Typo3 6.2.21

Added by Stefan no-lastname-given over 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2016-04-17
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Steps to reproduce:
1. Log in the backend
2. Click on Admin Tools -> Extension Manager
3. Select "Get Extensions"
4. Click on "Update Now"

Actual result:
A pop-up appears: "Update Extension List error(Internal Server Error):"
(see attached screenshot)

Expected result:
Extension list is updated.

Note: The issue started after upgrading from Typo3 6.2.19 to 6.2.21. Downgrading to 6.2.19 again and retesting showed that updating the extension list works again. Hence, assuming a regression in 6.2.20 or 6.2.21 here.

typo3_bug.jpg View (5.29 KB) Stefan no-lastname-given, 2016-04-17 15:22


Related issues

Related to TYPO3 Core - Bug #75022: XMLReader::open(): Unable to open source data in EM and Language module Closed 2016-03-11
Duplicated by TYPO3 Core - Bug #76057: Update Extension List failed with error message: Unable to parse file resource compress.zlib Closed 2016-05-05

Associated revisions

Revision 4e5b0e00 (diff)
Added by Oliver Hader over 3 years ago

[BUGFIX] Use push parser instead of pull parser on fetching extension list

Issue #75022 reported problems with libxml and operations on compressed
file streams. The work around for that patch showed drawbacks with memory
consumption. That's why the push parser is used as default now.

Resolves: #75721
Related: #75022
Releases: master, 7.6, 6.2
Change-Id: I6daadd4b375634cf45272bb249e4bfa083f03646
Reviewed-on: https://review.typo3.org/48189
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Markus Klein <>
Reviewed-by: Nicole Cordes <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision 7f93c99c (diff)
Added by Oliver Hader over 3 years ago

[BUGFIX] Use push parser instead of pull parser on fetching extension list

Issue #75022 reported problems with libxml and operations on compressed
file streams. The work around for that patch showed drawbacks with memory
consumption. That's why the push parser is used as default now.

Resolves: #75721
Related: #75022
Releases: master, 7.6, 6.2
Change-Id: I6daadd4b375634cf45272bb249e4bfa083f03646
Reviewed-on: https://review.typo3.org/48188
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision 1b58942b (diff)
Added by Oliver Hader over 3 years ago

[BUGFIX] Use push parser instead of pull parser on fetching extension list

Issue #75022 reported problems with libxml and operations on compressed
file streams. The work around for that patch showed drawbacks with memory
consumption. That's why the push parser is used as default now.

Resolves: #75721
Related: #75022
Releases: master, 7.6, 6.2
Change-Id: I6daadd4b375634cf45272bb249e4bfa083f03646
Reviewed-on: https://review.typo3.org/48187
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Markus Klein over 3 years ago

  • Status changed from New to Needs Feedback

Can you take a look at the server logs please? The error.log should contain more info.

#2 Updated by Stefan no-lastname-given over 3 years ago

Here's the related Apache log entry:
PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 39583744 bytes) in /var/www/typo3/typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php on line 59, referer: http://luke1410.de/typo3/typo3/mod.php?M=tools_ExtensionmanagerExtensionmanager&moduleToken=af02d9ff8b0c8071512e8b76bc1d537efe584142&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Baction%5D=ter&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Bcontroller%5D=List

#3 Updated by Markus Klein over 3 years ago

  • Status changed from Needs Feedback to New

Thanks Stefan.

#4 Updated by Henrik Ziegenhain over 3 years ago

I had the same issue on one installation.
The memory_limit was set to 64M in php.ini - increasing it to suggested 100M solved the issue for me.

#5 Updated by Jens Dede over 3 years ago

I think, I have a similar issue with 6.2.21:
When I try to upload my extension list, I get the following message:

Unable to parse file resource compress.zlib:///kunden/homepages/39/d71054028/htdocs/myWebpage/typo3temp/1.extensions.xml.gz.

The Typo3 log shows three errors:

Core: Error handler (BE): PHP Warning: XMLReader::XML(): Unable to load source data in /homepages/39/d71054028/htdocs/myWebpage/typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59 
Core: Error handler (BE): PHP Warning: XMLReader::XML(): Memory allocation failed : growing buffer in /homepages/39/d71054028/htdocs/myWebpage/typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59 
Core: Error handler (BE): PHP Warning: XMLReader::XML(): Memory allocation failed : growing buffer in /homepages/39/d71054028/htdocs/myWebpage/typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59 
My PHP Settings:
  • PHP 5.6.20
  • memory_limit 256MB
  • xml support enabled
  • zlib registered

Unfortunately, I do not have access to the server error log files...

A downgrade to 6.2.19 solves the problem.

#6 Updated by Oliver Hader over 3 years ago

Interesting... the error in issue #75022 was "unable to open source data", the report here is "unable to load source data".

The reader is initialized using libxml2 functions:

So, in general... the issue we tried to solve in #75022 is still present and the work-around only works for parts.
From my point of view, it makes sense to upgrade libxml2 on the systems where this happens.

#7 Updated by Stephan Großberndt over 3 years ago

As stated in https://forge.typo3.org/issues/75022 there are cases where libxml 2.9.1 does work and 2.9.2 doesn't - so I don't think this will help.

#8 Updated by Jens Dede over 3 years ago

In my case, I am using libxml 2.7.8 and it doesn't work.

#9 Updated by Stephan grass over 3 years ago

I have the same Problem with 7.6.6
Memory allocation failed : growing buffer in ... ExtensionXmlPullParser.php line 60
The site is hosted by 1&1

#10 Updated by Jens Dede over 3 years ago

I'm also using 1&1 as hosting provider. But until now, I never faced any problems with my TYPO3 and 1&1...

#11 Updated by Jens Dede over 3 years ago

Just updated to 6.2.22: Same issue:

Core: Error handler (BE): PHP Warning: XMLReader::XML(): Unable to load source data in ...typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59     
Core: Error handler (BE): PHP Warning: XMLReader::XML(): Memory allocation failed : growing buffer in ...typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59     
Core: Error handler (BE): PHP Warning: XMLReader::XML(): Memory allocation failed : growing buffer in ...typo3_src/typo3/sysext/extensionmanager/Classes/Utility/Parser/ExtensionXmlPullParser.php line 59 

Memory limit is 256M, System environment check shows all green...

Any suggestions or ideas?

#12 Updated by Björn Heinermann over 3 years ago

Hi,

I have the same problem with TYPO3 6.2.2 on a Mittwald Hosting. The "System environment check" is OK. Our TYPO3 6.2.2 systems on own webservers works correct. Very strange.

Best wishes
Björn

#13 Updated by Jens Dede over 3 years ago

Hi Björn,

what is your php memory limit? I'm facing this problem with 256M RAM but according to the documentation, TYPO3 6.2 should work with only 64M.
Articles and posts about similar issues recommend increasing the limit which is unfortunately not possible in case of shared hosting providers.

Maybe someone with a Typo3 6.2 installation and root access (or at least write access to the php.ini) can try reducing the memory limit to 256M and test if the update of the extension list still works. If yes -> should be something else. If no, either the required memory limit for Typo3 should be increased or the function causing the problems should be rewritten / replaced.

Or am I wrong? Comments?

Best regards,

Jens

#14 Updated by Jens Dede over 3 years ago

I updated my version to 7.6.6: Same problem. Downgrade to 7.6.4: Everything works fine.

So I think Oliver is right: The issue from #75022 still seems to be open... Shall we reopen #75022?

Best regards,

Jens

#15 Updated by Oliver Hader over 3 years ago

I looks like we should revert the change for #75022 to solve the regression with memory limits as a first step.
Then we need to focus (again) on the problems with libxml and possibly the compressed input stream.

#16 Updated by Stephan Großberndt over 3 years ago

  • Priority changed from Should have to Must have

+1

#17 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48187

#18 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48188

#19 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48189

#20 Updated by Oliver Hader over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#21 Updated by Stefan no-lastname-given over 3 years ago

Thanks for the fix for everybody involved.
Fix confirmed with 6.2.23.

#22 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF