Bug #76236

INCLUDE_TYPOSCRIPT condition PIDinRootline does not work correcty

Added by König David over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2016-05-19
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I try to use an condition for Including on an MultiDomain Websites different TS for different sites.

<INCLUDE_TYPOSCRIPT: source="FILE:path/to/the/first/domain/main.ts-setup" condition="[PIDinRootline=1]">

now if i go to firstdomain.test the TypoScript is not included. if i go to firstdomain.test/?index.php?id=1 the Typoscript is included correctly. And the Rootpage is Pid = 1
if I Include the file like this:

[PIDinRootline=1]
<INCLUDE_TYPOSCRIPT: source="FILE:path/to/the/first/domain/main.ts-setup">

it works correctly, but with the Problem that i can not use any conditions inside.


Related issues

Related to TYPO3 Core - Feature #16525: "<INCLUDE_TYPOSCRIPT:" and multi level conditions Closed 2006-09-04
Related to TYPO3 Core - Bug #80385: INCLUDE_TYPOSCRIPT is using wrong ConditionMatcher when using condition option Closed 2017-03-22

History

#1 Updated by Helmut Hummel over 1 year ago

  • Description updated (diff)
  • Status changed from New to Needs Feedback

you have:

<INCLUDE_TYPOSCRIPT: source="FILE:path/to/the/first/domain/main.ts-setup" condition="[PIDinRootline=1]">

but it should rather be:

<INCLUDE_TYPOSCRIPT: source="FILE:path/to/the/first/domain/main.ts-setup" condition="PIDinRootline=1">

(without square brackets in the condition)

Does this help?

#2 Updated by Andreas Allacher over 1 year ago

Maybe the issue occurs because of #80385?

#3 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again or have more info about how to reproduce it, then please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF