Bug #76281

Change 47369 killed features in flux

Added by Benedict Burckhart over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2016-05-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The Exception in change https://review.typo3.org/#/c/47379/ for nested elements kills the nested elements feature in flux.
See https://github.com/FluidTYPO3/flux/issues/1139

Maybe you can add a hook or a condition to deactivate it programmatically, so in flux the the Exception can be deactivated.


Related issues

Related to TYPO3 Core - Bug #73125: 500 Error in GroupElement.php due to group db fields in flexform containersClosedFrank Naegler2016-02-04

Actions
#1

Updated by Wouter Wolters over 5 years ago

  • Status changed from New to Needs Feedback

Did you read what the exception message contains?

Nesting type=inline in container sections is not supported. Throw an exception if configured.
Nesting sections is not supported. Throw an exception if configured.

Nesting flex form sections or inline within section containers is not supported.
To not let developers run into hard to track issues the patch adds an exception to detect these cases.

Additionally, GroupElement contains a preparation that is done by TcaGroup data provider already,
so this part is cleaned up along the way since this is unreachable code if FormEngine is used without nested sections.

#2

Updated by Wouter Wolters over 5 years ago

  • Assignee deleted (Christian Kuhn)
#3

Updated by Christian Kuhn over 5 years ago

  • Status changed from Needs Feedback to Rejected

Working with inline in section or with nested sections can result in various data integrity issues. Removing that exception would expose the system to that risk again. Core must stay on the safe side here.

This issue can only be closed at the moment.

#4

Updated by Claus Due over 5 years ago

I agree with the decisions and Christian is completely correct about the data integrity issues (see every Flux issue concerning sorting of section objects). I would add that Flux contained some workarounds to avoid those issues but we fully accept the decision to block these structures and any others that may have similar problems.

Also available in: Atom PDF