Bug #76638

Insertion point not correctly displayed when creating a sub page via context menu

Added by Jochen Weiland about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2016-06-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using the context menu in the page tree to insert a new page as a sub page to an existing page, the arrow for the insertion point is only displayed correct for the levels 0 and 1 of the page tree. Starting with level 2, the arrow for inserting a sub page is not connected via a dotted line to the parent page. See attached image. Clicking on this arrow actually inserts a sub page, so the functionality is correct, just the rendering of the dotted line as well as the identatioin of the arrow is incorrect. Tested with Chrom, Firefox and Safari.

Also on levels 0 and 1 the arrow to insert the new page as a sub page is attached to the wrong page. In the image below, if trying to insert a page by using the context menu on "Seite 1" the insert as sub-page appears attached to "Seite 2"

Best regards
Jochen


Files

2016-06-15_10-28-16.png (14.4 KB) 2016-06-15_10-28-16.png Jochen Weiland, 2016-06-15 10:46
2016-06-15_10-42-19.png (41.7 KB) 2016-06-15_10-42-19.png Jochen Weiland, 2016-06-15 10:46

Related issues

Related to TYPO3 Core - Bug #72957: Unclear position for the new page using the wizardClosedMichael Oehlhof2016-01-27

Actions
Has duplicate TYPO3 Core - Bug #76309: Tree display broken in insert new record viewClosed2016-05-26

Actions
Has duplicate TYPO3 Core - Task #77546: ImportsClosed2016-08-19

Actions
#1

Updated by Daniel Goerz about 5 years ago

  • Description updated (diff)
#2

Updated by Daniel Goerz about 5 years ago

  • Status changed from New to Closed

closed as duplicate, moved our description to the other ticket.

#3

Updated by Daniel Goerz about 5 years ago

  • Status changed from Closed to New

Description from the closed ticket #76309 by Stephan GroƟberndt

"When inserting a new record by clicking on a page in the tree and choosing "Page Actions"->"New" the treeview is broken - the second arrow (the first one below the record) should indicate you are inserting the new page as a subpage to the current - but it is displayed in the same level as the other both arrows. This is only a problem for the root and the first level as it seems."

#4

Updated by Riccardo De Contardi about 5 years ago

Is it the same of #72957 too? (or just related?)

#5

Updated by Tymoteusz Motylewski almost 5 years ago

  • Status changed from New to Closed

closing this one as duplicate of #72957

Also available in: Atom PDF