Bug #72957

Unclear position for the new page using the wizard

Added by Christian Toffolo almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
Backend User Interface
Start date:
2016-01-27
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

TYPO3 7.6
Editor uses the new page wizard and get confused on where the new page will be created looking at the tree of "Select a position for the new page:"
The indentation of the pages in the tree is wrong showing pages and sub-pages on the same level.

TYPO3 6.2 was simply right and clear.

Capture.PNG View (38.9 KB) Christian Toffolo, 2016-01-27 10:49

Capture2.PNG View (29.7 KB) Christian Toffolo, 2016-01-27 10:52

cattura.png View (15.7 KB) Riccardo De Contardi, 2016-01-28 10:23

cattura1.png View (16.1 KB) Riccardo De Contardi, 2016-06-13 14:33

cattura2.png View (48.4 KB) Riccardo De Contardi, 2016-06-13 14:33

newpagewizard.png View (57.1 KB) Christian Toffolo, 2016-06-13 14:35

Schermata 2016-10-23 alle 10.15.01.png View (56.2 KB) Riccardo De Contardi, 2016-10-23 10:22


Related issues

Related to TYPO3 Core - Bug #76638: Insertion point not correctly displayed when creating a sub page via context menu Closed 2016-06-15

Associated revisions

Revision 56b85b3d (diff)
Added by Michael Oehlhof about 3 years ago

[BUGFIX] Fix unclear position for the new page using the wizard

Resolves: #72957
Releases: master, 7.6
Change-Id: I06cee55c78365ff83a239fff71ef02a180009f30
Reviewed-on: https://review.typo3.org/50322
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

Revision 87797053 (diff)
Added by Michael Oehlhof about 3 years ago

[BUGFIX] Fix unclear position for the new page using the wizard

Resolves: #72957
Releases: master, 7.6
Change-Id: I06cee55c78365ff83a239fff71ef02a180009f30
Reviewed-on: https://review.typo3.org/50396
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

History

#1 Updated by Christian Toffolo almost 4 years ago

This is how the wizard looks in 4.7
I don't have a 6.2 actually but if I remember well was pretty the same.

#2 Updated by Riccardo De Contardi almost 4 years ago

  • Category set to Backend User Interface

#3 Updated by Riccardo De Contardi almost 4 years ago

I add a further weird behavior (I tested witht the latest master 8.0-dev):
As you can see from my screenshot Cattura.png, there is an arrow inside the page with id=339 ("Prova 32") that seems to create the page inside that page, but... it actually creates it below the page, at the same level

#4 Updated by Riccardo De Contardi over 3 years ago

  • Target version changed from 7.6.3 to Candidate for patchlevel

#5 Updated by Frank Naegler over 3 years ago

  • Status changed from New to Needs Feedback

can't reproduce the bug with latest 7.6 and master branch.
Is it still an issue?

#6 Updated by Christian Toffolo over 3 years ago

I just checked with latest 7.6 and bug is still present.

#7 Updated by Riccardo De Contardi over 3 years ago

In fact, IMO it is reproducible on 8.2-dev (I have not tested with 7.6, but I think that's the same)

steps to reproduce:
a) create a page named "72957", and create some subpages ("Alpha", "Beta", "Gamma"), so you have the situation illustrated on cattura1.png
b) select the page 72957"; list view; create new record; Create a new page (select position)
c) the result is shown in cattura2.png:

1) it is not clear from the position of the pages and the arrows, that the pages Alpha, Beta, Gamma are in fact inside 72957
2) looking at the last arrow, it seems that it creates a page inside Gamma, but it actually creates it after Gamma

#8 Updated by Christian Toffolo over 3 years ago

This is the actual screenshot of the latest commit of 7.6 from git with some note added to help to understand the bug.

#9 Updated by Michiel Roos about 3 years ago

This was broken in commit https://github.com/TYPO3/TYPO3.CMS/commit/2affe49148755ec49731dc24de47b452e8919437

Due to changes in the method: \TYPO3\CMS\Backend\Tree\View\AbstractTreeView::getTree()

#10 Updated by Tymoteusz Motylewski about 3 years ago

  • Status changed from Needs Feedback to New

confirmed in v8.3

#11 Updated by Michael Oehlhof about 3 years ago

  • Assignee set to Michael Oehlhof

#12 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50322

#13 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50322

#14 Updated by Christian Toffolo about 3 years ago

Patch works for me in TYPO3 7.6.11
Thank you Michael Oehlhof!

#15 Updated by Riccardo De Contardi about 3 years ago

Still not totally clear: if you are in the situation described by the attached screenshot Schermata 2016-10-23 alle 10.15.01.png and click on the arrow circled, the created page will not be a subpage of the page, but a sibling.

#16 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50322

#17 Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50322

#18 Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50322

#19 Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50396

#20 Updated by Michael Oehlhof about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#21 Updated by Christian Toffolo about 3 years ago

I tested https://review.typo3.org/#/c/50396/ and this bug doesn't seem to be resolved.
As I commented here https://review.typo3.org/#/c/50322/:
"If you try to create a page from a page that has no children, the arrow that signal the position for the sub-page of this page is not indented."

#22 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF