Bug #78666

Dependencies from a local extension are not resolved

Added by Nicole Cordes over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2016-11-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Following steps to reproduce:

- Try to install the attached extension

Expected result:

3 Extensions should be available and installed: a, b, and hosts_pattern (after the "I know what I'm doing" dialog was confirmed due to TYPO3 version)

Actual result:

Fatal error because hosts_pattern was not downloaded and installed.

There are several problems during the installation of an extension:

1) The information for downloading and updating dependencies is fetched to early. The queue is retrieved before local extensions were copied and its dependencies were added to the queues.
2) The queues are processed only once. This means new downloads and/or updates are not processed anymore.
3) The ordering of extensions that need to be installed is mixed up. Extensions which were added at last to the queue are dependencies of earlier ones and need to be installed first.


Files

a_1.0.0_201611121042.zip (2.6 KB) a_1.0.0_201611121042.zip Nicole Cordes, 2016-11-12 10:42
CMS Ext.zip (4.62 KB) CMS Ext.zip Markus Klein, 2016-11-13 11:12

Related issues

Related to TYPO3 Core - Bug #78677: EM fails to install 4th level dependency of extensionsClosedNicole Cordes2016-11-13

Actions

Also available in: Atom PDF