Bug #78731

RTE - Regular Text Element - Fullscreen Rich Text Editing doesn't work

Added by Krzysztof Napora over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2016-11-17
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
7.6.12
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I click on the button "Fullscreen Rich Text Editing" , RTE is not show on full width. It's look like here :

!!

It also checked for the newest version for TYPO3 v 6.2.x and it show the RTE on full width.
I checked this for the TYPO3 version 7.6.12

Zrzut ekranu 2016-11-17 10.36.54.png View (52.8 KB) Krzysztof Napora, 2016-11-17 10:41


Related issues

Related to TYPO3 Core - Bug #79941: Full screen RTE width Closed 2017-02-21
Related to TYPO3 Core - Task #80636: Fix Forge #78731 RTE - Regular Text Element - Fullscreen Rich Text Ed… Rejected 2017-04-02

Associated revisions

Revision f7031cbf (diff)
Added by Wouter Wolters about 1 year ago

[BUGFIX] Fix check to determine RTEhtmlarea is in fullscreen mode

Due to the implementation of routes the check fails. Check against
the route instead.

Resolves: #78731
Releases: 7.6
Change-Id: Ifef945aa076c36755bc7193bc4702651402181c7
Reviewed-on: https://review.typo3.org/52339
Tested-by: TYPO3com <>
Reviewed-by: Rudy Gnodde <>
Tested-by: Rudy Gnodde <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi over 1 year ago

As far as I can see the button works (because it opens the RTE in a "standalone" view), but the width of the RTE remains hardcoded (via javascript, I guess)

<div id="data_tt_content__61__bodytext_-htmlArea" class="htmlarea" style="width: 680px; height: 472px;">

#2 Updated by Riccardo De Contardi over 1 year ago

  • Category set to RTE (rtehtmlarea + ckeditor)

#3 Updated by Georg Tiefenbrunn over 1 year ago

This bug ic caused by function isInFullScreenMode() and recently got fixed for 8.x (see https://github.com/TYPO3/TYPO3.CMS/commit/84be5e616b5373ac7ba57edf2d3cd61251dc6f97#diff-98718d69fcb4f351fb32d269256225dbL1239).

Version 7.6 still checks _GP('M') === 'wizard_rte' instead of _GP('route') === '/wizard/rte' (see https://github.com/TYPO3/TYPO3.CMS/blob/TYPO3_7-6/typo3/sysext/rtehtmlarea/Classes/Form/Element/RichTextElement.php#L1319).

#4 Updated by Leonie Philine Bitto about 1 year ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel

This also affects me. Can we please have the TYPO3 8 fix also on 7.6.17? Thanks!
Definitely a broken feature due to introduction of BE routes, and must be fixed in a bugfix release.

#6 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52339

#7 Updated by Wouter Wolters about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF