Project

General

Profile

Actions

Bug #78803

closed

ResourceCompressor can't deal with paths relative to docroot

Added by Markus Klein over 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Content Rendering
Target version:
Start date:
2016-11-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

FormEngine adds absolute web paths to the array of CSS/JS files.
The ResourceCompressor fails to deal with them.

The bug appears once compression for BE is enabled and the instance is located in a subdirectory of docroot.

The error can be triggered by simply editing a content element, which includes an RTE.

PHP Warning: file_get_contents(/var/www/html/thesite/typo3//thesite/typo3/sysext/rtehtmlarea/Resources/Public/Css/Skin/jquery-ui-resizable.css): failed to open stream: No such file

Related issues 8 (1 open7 closed)

Related to TYPO3 Core - Bug #78490: file_get_contents fail prevents page tree to renderClosedNicole Cordes2016-10-28

Actions
Related to TYPO3 Core - Bug #78856: Page Tree is not loadedClosed2016-12-01

Actions
Related to TYPO3 Core - Bug #79218: ResourceCompressor.php PHP Warning: is_file(): open_basedir restriction in effectClosed2017-01-09

Actions
Related to TYPO3 Core - Bug #82863: ResourceCompressor can't deal with paths relative to docrootClosedMarkus Klein2017-10-26

Actions
Related to TYPO3 Core - Bug #95848: ResourceCompressor can't deal with paths relative to docroot (Reoccurrence)Needs Feedback2021-11-02

Actions
Has duplicate TYPO3 Core - Bug #78807: fresh installation 8.4.1 into subdirectory leads to semi-broken TYPO3Closed2016-11-26

Actions
Precedes TYPO3 Core - Bug #81115: TYPO3-Exception in BE-Log due to "PHP Warning: is_file(): open_basedir restriction in effect"Closed2016-11-282016-11-28

Actions
Precedes TYPO3 Core - Bug #81024: getFilenameFromMainDir() triggers PHP Warnings open_basedirClosedChristian Toffolo2016-11-282016-11-28

Actions
Actions #1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50782

Actions #2

Updated by Markus Klein over 7 years ago

  • Sprint Focus set to Stabilization Sprint
Actions #3

Updated by Markus Klein over 7 years ago

  • Description updated (diff)
Actions #4

Updated by Markus Klein over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Markus Klein about 7 years ago

  • Status changed from Resolved to Accepted

Patch has been reverted.

Actions #6

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50921

Actions #7

Updated by Markus Klein about 7 years ago

  • Status changed from Under Review to Resolved
Actions #8

Updated by Markus Klein almost 7 years ago

  • Description updated (diff)
Actions #9

Updated by Stephan Großberndt almost 7 years ago

  • Precedes Bug #81115: TYPO3-Exception in BE-Log due to "PHP Warning: is_file(): open_basedir restriction in effect" added
Actions #10

Updated by Stephan Großberndt almost 7 years ago

  • Precedes Bug #81024: getFilenameFromMainDir() triggers PHP Warnings open_basedir added
Actions #11

Updated by Markus Klein over 6 years ago

  • Related to Bug #82863: ResourceCompressor can't deal with paths relative to docroot added
Actions #12

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions #13

Updated by Markus Klein over 1 year ago

  • Related to Bug #95848: ResourceCompressor can't deal with paths relative to docroot (Reoccurrence) added
Actions

Also available in: Atom PDF