Bug #79062

Filelist allows metadata translation for disabled languages

Added by Alexander Stehlik almost 4 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-12-21
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

Steps to reproduce:

  • Create a new sys_language (German)
  • Create a new sys_langauge (Danish)
  • Disable the sys_language
  • Open the file list module
  • Click on the icon for creating a new file metadata translation

Current behavior

Both languages show up (German and Danish).

Expected behavior

Only the German langauge is available (because Danish is disabled).


Related issues

Related to TYPO3 Core - Bug #59947: getSystemLanguages() method in TranslationConfigurationProvider does not respect enable fields Closed 2014-06-27
Related to TYPO3 Core - Task #59004: Code Cleanups in TranslationConfigurationProvider Closed 2014-05-21

History

#1 Updated by Alexander Stehlik almost 4 years ago

  • Description updated (diff)
  • TYPO3 Version changed from 8 to 7
  • Is Regression changed from No to Yes

Seems to be a regression introduced in https://review.typo3.org/#/c/30258

#2 Updated by Riccardo De Contardi about 3 years ago

This issue is still present on TYPO3 7.6.22, but is solved in 8.7.6 and 9.0.0-dev (master)

#3 Updated by Christian Kuhn almost 3 years ago

unsure if we should still change this in 7.6 - probably not that critical.

#4 Updated by Stefan Neufeind almost 3 years ago

  • Status changed from New to Rejected

@Christian: I agree, not for v7 anymore.

Also available in: Atom PDF