Bug #80384

TYPO3 page tree: context menu not closed after enabling page via context menu

Added by Josef Glatz over 2 years ago. Updated 11 months ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
Pagetree
Start date:
2017-03-21
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Problem/Description

When you disable a page via context menu -> the context menu is closed due a reload of hte page tree frame.
When you enable a disabled page via context menu -> the context menu isn't closed.

ToDo(s)

  • The TYPO3 page tree context menu should be closed after enabling a disabled page

Acceptance Criteria

*

History

#1 Updated by Frank Naegler over 2 years ago

  • Status changed from New to Needs Feedback

can't reproduce with current master, is this bug is still valid? If yes, please provide some more informations about browser and version.

#2 Updated by Benni Mack over 2 years ago

  • Target version changed from 8 LTS to Candidate for patchlevel

#3 Updated by Josef Glatz about 2 years ago

Short update:

Seems like a race condition. I've tried to reproduce the problem with 8-LATEST dev:

First try

problem was still reproducible

Second try

problem wasn't reproducible

The problem occurs occasionally when working with the backend in real projects. Often there's also the problem, that an click on an already "active" page in the pagetree didn't do anything. But as already mentioned: occasionally. Some race condition.


Environemnt: macOS El Capitan with still the latest stable Google Chrome browser. Didn't try other browsers often enough to make a statement about that.

#4 Updated by Riccardo De Contardi almost 2 years ago

  • Parent task set to #53915

#5 Updated by Alexander Opitz over 1 year ago

  • Status changed from Needs Feedback to New

#6 Updated by Benni Mack 11 months ago

  • Parent task deleted (#53915)

Still reproducable with v9

Also available in: Atom PDF