Feature #80559

datetime and time handling should always have timezone information

Added by Bernd Wilke over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-03-29
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

each input or output should be able to handle timezones.
so an editor might enter a time and his local timezone must be respected before the time is stored as UTC in the DB. (not every editor is capable to calculate UTC time from local time)

so a setting for the timezone of the user is needed (User settings)
and also every time /datetime field should have its own timezone field (preset with user settings) so an editor also can enter data for other timezones.

so the input could be saved in a clean way as UTC.

for output (or visibilty checks) the server timezone could be default, but might be set in a viewhelper, typoscript or php for generating output for other locations.
maybe a special setting 'visitor' to render the time depending on visitors location (if that information is available)


Related issues

Related to TYPO3 Core - Feature #64372: Add timezone-handling for value-display depending on FE-userNeeds Feedback2015-01-20

Actions
Related to TYPO3 Core - Bug #66793: "simulate time" in admin-panel does not respect timezoneClosed2015-05-05

Actions
Related to TYPO3 Core - Bug #68651: Datetime() properties have wrong timezoneAcceptedAndreas Wolf2015-07-30

Actions
Related to TYPO3 Core - Bug #79613: Saving wrong Date into DB if Field is of type DATENew2017-02-03

Actions
Related to TYPO3 Core - Bug #80349: Extbase mapping of \DateTime for integer values does not set timezone with region string but only offsetNew2017-03-20

Actions
Is duplicate of TYPO3 Core - Feature #61110: Support for timezones in all date fields in TYPO3 BENew2014-08-21

Actions
#1

Updated by Mona Muzaffar over 4 years ago

  • Related to Epic #80852: Datetime handling in backend added
#2

Updated by Riccardo De Contardi about 4 years ago

  • Parent task set to #77562
#3

Updated by Markus Klein about 4 years ago

  • Status changed from New to Closed

Closed as duplicate of #61110

#4

Updated by Markus Klein about 4 years ago

  • Is duplicate of Feature #61110: Support for timezones in all date fields in TYPO3 BE added
#5

Updated by Markus Klein about 4 years ago

  • Parent task deleted (#77562)
#6

Updated by Markus Klein about 4 years ago

  • Related to deleted (Epic #80852: Datetime handling in backend)

Also available in: Atom PDF