Bug #81095

Indexed Search Label "displayResults" not translatable by TypoScript

Added by David Rellstab about 2 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2017-05-01
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When trying to override the label "displayResults" in TypoScript:

_LOCAL_LANG {
fr {
displayResults = mytranslation
}
}

nothing happens and the default language output is shown.

Associated revisions

Revision e7882f44 (diff)
Added by Susanne Moog almost 2 years ago

[BUGFIX] _LOCAL_LANG overwrite via TypoScript with nested keys

If language labels are set for the top level key and sub
keys in TypoScript the top level key was not taken into
account as it got stored with 'typoScriptNodeValue' as key.

Special handling for that specific key was introduced, to
make overwriting of top level keys possible again.

Change-Id: Ibd5f5a939b1de530ba93840cfb7ba5ab5bc85c2f
Resolves: #81095
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/53701
Tested-by: TYPO3com <>
Reviewed-by: Joerg Boesche <>
Tested-by: Joerg Boesche <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision b988ba84 (diff)
Added by Susanne Moog almost 2 years ago

[BUGFIX] _LOCAL_LANG overwrite via TypoScript with nested keys

If language labels are set for the top level key and sub
keys in TypoScript the top level key was not taken into
account as it got stored with 'typoScriptNodeValue' as key.

Special handling for that specific key was introduced, to
make overwriting of top level keys possible again.

Change-Id: Ibd5f5a939b1de530ba93840cfb7ba5ab5bc85c2f
Resolves: #81095
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/53704
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Needs Feedback

Hi @David Rellstab, I am not able to reproduce it with the version 8.7.4

I used in TS Setup:

plugin.tx_indexedsearch{
_LOCAL_LANG{
  default.displayResults = Displaying my own results <strong>%1$s to %2$s</strong> out of <strong>%3$s</strong>
  it.displayResults = Visualizza i miei risultati da <strong>%1$s a %2$s</strong> di <strong>%3$s</strong>
  }

}

Can you add more information about your configuration and how to reproduce it? Thank you!

#2 Updated by Susanne Moog almost 2 years ago

  • Status changed from Needs Feedback to Accepted

@Riccardo: It doesn't work if you have included the default TypoScript of indexed_search, OR:


plugin.tx_indexedsearch{
_LOCAL_LANG{
  default.displayResults = Displaying my own results <strong>%1$s to %2$s</strong> out of <strong>%3$s</strong>
  default.displayResults.next = >>>
  }
}

The problem occurs when a toplevel key exists and additionally sub-keys are used.

#3 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53701

#4 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53704

#5 Updated by Anonymous almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

#7 Updated by Sebastian Schmal 6 months ago

  • Priority changed from Should have to Must have

A new Bug is here:
the typoscript dont work with HTML !

displayResults.previous = &lt; test
displayResults.next = test &gt;

#8 Updated by Josef Glatz 6 months ago

Sebastian Schmal wrote:

A new Bug is here:
the typoscript dont work with HTML !

[...]

Hey Sebastian, if it's a new bug you have to better create a new issue as this issue is already closed

Also available in: Atom PDF