Bug #81297

Extbase record preview leads to 404 due to missing cHash

Added by Mathias Brodala over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2017-05-22
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

With #78002 the cHash is enforced for Extbase plugins if arguments are present. This however breaks the record preview feature since it does not add a cHash argument but uses no_cache instead.

A possible fix could be #78336 which adds an option to enable cHash calculation for record preview URLs.


Related issues

Related to TYPO3 Core - Bug #78002: Require cHash for cached plugin actions in Extbase Closed 2016-09-20
Related to TYPO3 Core - Bug #78336: Avoid usage of no_cache in preview link configuration Closed 2016-10-18

Associated revisions

Revision 0aa5f2b4 (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Make it possible to add cHash to preview links

It must be possible to generate preview URLs with a cHash, e.g. to
display records using Extbase which enforces cHash usage.

Introduce a new option "useCacheHash" which triggers cHash calculation.
If not specified, the "no_cache" parameter is added just like before.

Resolves: #78336
Resolves: #81297
Releases: master, 8.7
Change-Id: I225e2b8b4355022e7b4f6866c989b707e526e389
Reviewed-on: https://review.typo3.org/50264
Reviewed-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

Revision c3e9b275 (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Make it possible to add cHash to preview links

It must be possible to generate preview URLs with a cHash, e.g. to
display records using Extbase which enforces cHash usage.

Introduce a new option "useCacheHash" which triggers cHash calculation.
If not specified, the "no_cache" parameter is added just like before.

Resolves: #78336
Resolves: #81297
Releases: master, 8.7
Change-Id: I225e2b8b4355022e7b4f6866c989b707e526e389
Reviewed-on: https://review.typo3.org/55255
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Tested-by: TYPO3com <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Mathias Brodala over 2 years ago

  • Related to Bug #78002: Require cHash for cached plugin actions in Extbase added

#2 Updated by Mathias Brodala over 2 years ago

  • Related to Bug #78336: Avoid usage of no_cache in preview link configuration added

#3 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#5 Updated by Richard Haeser over 2 years ago

Any news on this? Needs help?

#6 Updated by Mathias Brodala about 2 years ago

Richard Haeser wrote:

Any news on this? Needs help?

It needs a decision whether to keep it as breaking feature or turn it int a non-breaking bugfix. But I'll probably just go ahead with the latter since there is nothing to lose.

#7 Updated by Gerrit Code Review about 2 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#8 Updated by Gerrit Code Review about 2 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#9 Updated by Gerrit Code Review about 2 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#10 Updated by Gerrit Code Review almost 2 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#11 Updated by Gerrit Code Review almost 2 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#12 Updated by Gerrit Code Review almost 2 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#13 Updated by Gerrit Code Review almost 2 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#14 Updated by Gerrit Code Review almost 2 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#15 Updated by Gerrit Code Review almost 2 years ago

Patch set 19 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#16 Updated by Gerrit Code Review almost 2 years ago

Patch set 20 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#17 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#18 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55255

#19 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55255

#20 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved

#21 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF