Bug #81700

Images get sharpend even if [GFX][processor_effects] is set to -1

Added by Klaus Moser over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Image Generation / GIFBUILDER
Target version:
-
Start date:
2017-06-26
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the current 8.7.2 version images are sharpened even if [GFX][processor_effects] is set to -1 (Do not sharpen images by default).

The reason for that is a wrong if condition in typo3/sysext/core/Classes/Imaging/GraphicalFunctions.php on line 371.

is:

if ($gfxConf['processor_effects']) {
    $this->NO_IM_EFFECTS = 0;
    $this->cmds['jpg'] .= $this->v5_sharpen(10);
    $this->cmds['jpeg'] .= $this->v5_sharpen(10);
}

should be:

if ($gfxConf['processor_effects'] > 0) {
    $this->NO_IM_EFFECTS = 0;
    $this->cmds['jpg'] .= $this->v5_sharpen(10);
    $this->cmds['jpeg'] .= $this->v5_sharpen(10);
}

Related issues

Related to TYPO3 Core - Bug #83591: GraphicsMagick + [GFX][processor_effects] = '0' is set to '-1' just by entering the Install Tool Closed 2018-01-17
Related to TYPO3 Core - Bug #85059: Use int cast to prevent comparison failures Closed 2018-05-22

Associated revisions

Revision d6ca05c8 (diff)
Added by Guido S. over 1 year ago

[BUGFIX] Do not sharpen images if GFX/processor_effects is -1

Sharpen images only if the install tool setting GFX/processor_effects is
set to 1 and not if it is set to 0 or -1

Resolves: #81700
Releases: 8.7
Change-Id: I0eab123720741b2f965bf9fc3767914ce46aaba0
Reviewed-on: https://review.typo3.org/56494
Reviewed-by: Stephan Großberndt <>
Tested-by: TYPO3com <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision a49d5c52 (diff)
Added by Frank Naegler over 1 year ago

[BUGFIX] Add int cast for GFX/processor_effects check

Resolves: #85059
Related: #81700
Releases: 8.7
Change-Id: Icf7112d938c7905e2c9bda03a9b48cc8e9cfac0b
Reviewed-on: https://review.typo3.org/57023
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Stefan P over 1 year ago

I can confirm this issue. After upgrading to TYPO3 8 the images suddenly get sharpened and this is most likely the cause.

#2 Updated by Riccardo De Contardi over 1 year ago

  • Category set to Image Generation / GIFBUILDER

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56494

#4 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56494

#5 Updated by Stephan Großberndt over 1 year ago

  • Related to Bug #83591: GraphicsMagick + [GFX][processor_effects] = '0' is set to '-1' just by entering the Install Tool added

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56494

#7 Updated by Guido S. over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Frank Naegler over 1 year ago

  • Related to Bug #85059: Use int cast to prevent comparison failures added

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF