Bug #83591

GraphicsMagick + [GFX][processor_effects] = '0' is set to '-1' just by entering the Install Tool

Added by Stefan P over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Install Tool
Target version:
-
Start date:
2018-01-17
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Whenever entering the Install Tool, the setting [GFX][processor_effects] is set to '-1'.

I started with the GraphicsMagick preset and altered the LocalConfiguration.php by hand, setting [GFX][processor_effects] to '0'. This works until I click again on the Install Tool module. Navigating within the Install Tool directly after changing the value, you have to re-enter the Install Tool completly.

I work-around this by setting the value in AdditionalConfiguration.php which takes precedence over LocalConfiguration.php, but ideally this should be fixed in the core.

Bug #81700 is probably related. I'm not sure if this happens with ImageMagick as well, because I only have access to GraphicsMagick in the setup where I encountered this.


Related issues

Related to TYPO3 Core - Bug #81700: Images get sharpend even if [GFX][processor_effects] is set to -1 Closed 2017-06-26
Related to TYPO3 Core - Task #82768: Graphics API Closed 2017-10-16

Associated revisions

Revision 1b869d7a (diff)
Added by Marc Willmann about 1 year ago

[BUGFIX] Remove reset of GFX/processor_effects to -1

When entering the Install Tool and the GFX/processor is set to
GraphicsMagick the value for GFX/processor_effects is reset to -1,
overwriting any value that might have been set before.
Also adjust tests for the new expectations.

Resolves: #83591
Releases: master, 8.7
Change-Id: I7baa247a404166332a9a727983bb5eb83dfe37af
Reviewed-on: https://review.typo3.org/57319
Tested-by: TYPO3com <>
Reviewed-by: Fabien Udriot <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

Revision 7b0f18eb (diff)
Added by Marc Willmann about 1 year ago

[BUGFIX] Remove reset of GFX/processor_effects to -1

When entering the Install Tool and the GFX/processor is set to
GraphicsMagick the value for GFX/processor_effects is reset to -1,
overwriting any value that might have been set before.
Also adjust tests for the new expectations.

Resolves: #83591
Releases: master, 8.7
Change-Id: I7baa247a404166332a9a727983bb5eb83dfe37af
Reviewed-on: https://review.typo3.org/57339
Tested-by: TYPO3com <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

Revision 5d0fdb37 (diff)
Added by Mathias Brodala about 1 year ago

[TASK] Drop unused code in SilentConfigurationUpgradeService

This removes unused code which is left over from the fix for #83591.

Resolves: #83591
Releases: 8.7
Change-Id: Ibdf283c973e333ec7eb6d1ecb82fe0198465b69e
Reviewed-on: https://review.typo3.org/57395
Reviewed-by: Benni Mack <>
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>

Revision 0c5436ae (diff)
Added by Mathias Brodala about 1 year ago

[TASK] Migrate "GFX/processor_effects" to boolean

Ensure "GFX/processor_effects" is a true boolean as suggested in
the settings module and silently migrate integer/string values
accordingly.

Resolves: #83591
Releases: master
Change-Id: I006e907e75e273009333363a4d42661183ba8721
Reviewed-on: https://review.typo3.org/57391
Reviewed-by: Benni Mack <>
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Frans Saris <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Stefan P over 1 year ago

Whoops, the unfinished sentence should read:
Navigating within the Install Tool directly after changing the value does not trigger the effect, you have to re-enter the Install Tool completly (which immediatly triggers it).

#2 Updated by Susanne Moog over 1 year ago

  • Category set to Install Tool

#3 Updated by Stephan GroƟberndt over 1 year ago

  • Related to Bug #81700: Images get sharpend even if [GFX][processor_effects] is set to -1 added

#4 Updated by Guido S. over 1 year ago

It's not a bug, it's a feature :-)

typo3\sysext\install\Classes\Service\SilentConfigurationUpgradeService.php checks if GraphicsMagick is active, and return -1 for processor_effects for GM:

        if ((string)$currentProcessorValue !== '') {
            if ($currentProcessorMaskValue != 0) {
                $changedValues['GFX/processor_allowTemporaryMasksAsPng'] = 0;
            }
            if ($currentProcessorValue === 'GraphicsMagick') {
                if ($currentProcessorEffectsValue != -1) {
                    $changedValues['GFX/processor_effects'] = -1;
                }
            }
        }

This could be a historic decision because sharpen might not always be available to GM. The code is also active in the current master.

My two cents: We can remove this check, see current gm doc: http://www.graphicsmagick.org/GraphicsMagick.html#details-sharpen If a gm version does not support sharpen, you can disable this manually at processor_effects.

#5 Updated by Riccardo De Contardi over 1 year ago

  • Sprint Focus set to On Location Sprint

#6 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57319

#7 Updated by Susanne Moog about 1 year ago

  • Assignee set to Marc Willmann

#8 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57324

#9 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57319

#10 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57319

#11 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57339

#12 Updated by Marc Willmann about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57391

#14 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57391

#15 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57391

#16 Updated by Mathias Brodala about 1 year ago

#17 Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57391

#18 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57395

#19 Updated by Mathias Brodala about 1 year ago

  • Status changed from Under Review to Resolved

#20 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF