Bug #81761

l10n_mode exclude is ignored in IRRE relations and deletes unrelated child records during l10n

Added by Philipp Gampe about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2017-06-30
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

If a records has a child records as IRRE relation with foreign field,
but the child records also exist freely without parent record and the
default value for the foreign field is 0 (Zero), then translating
the parent records will delete all child records without a parent.

Bonus: If the child records is not translatable, a "translated" child
record is created anyway.

Expected behavior:
Translated parent and do not show child record IRRE in the translation
(Formengine).
Free children are left alone.
Bonus: Do not create a new child record for each translation.

Actual behavior:
Child record relation is not shown in translation (form engine). [correct]
All free children are removed. [big problem]
Bonus: A new child record is created for each translation. [small problem]

Workaround:
Make the default value for the foreign field not zero (e.g. -1).

phil_foreign_0.0.0_201706301941.zip - Sample extension (3.02 KB) Philipp Gampe, 2017-06-30 19:41


Related issues

Related to TYPO3 Core - Task #79244: Streamline l10n_mode exclude data processing Needs Feedback
Related to TYPO3 Core - Task #78745: Get rid of localizationMode of TCA type inline Closed 2016-11-18
Related to TYPO3 Core - Bug #80460: l10n_mode exclude without sync in T3 8.6.1 Closed 2017-03-26
Related to TYPO3 Core - Bug #83117: l10n_mode exclude IRRE Relations are translated Rejected 2017-11-27

History

#1 Updated by Philipp Gampe about 2 years ago

Steps to reproduce

1. Install the sample extension
2. Create a bunch of children records
3. Create parent record with an inline child
4. Create a translation of the parent record
5. Miss a few children

#2 Updated by Philipp Gampe about 2 years ago

  • Related to Task #79244: Streamline l10n_mode exclude data processing added

#3 Updated by Philipp Gampe about 2 years ago

  • Related to Task #78745: Get rid of localizationMode of TCA type inline added

#4 Updated by Philipp Gampe about 2 years ago

  • Related to Bug #80460: l10n_mode exclude without sync in T3 8.6.1 added

#5 Updated by Susanne Moog over 1 year ago

  • Related to Bug #83117: l10n_mode exclude IRRE Relations are translated added

#6 Updated by Oliver Hader over 1 year ago

  • Status changed from New to Needs Feedback

I could not reproduce the behavior in TYPO3 v9.2-dev nor in TYPO3 v8.7.11-dev.
However, I could identify that child elements (which are not localizable) are not synchronized in case the language parent record is updated.

Can you please check, whether the original bug still exists in recent TYPO3 versions? Thanks!

#7 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF