Bug #81763

Migrate file edit form to FormEngine

Added by Andreas Fernandez over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
Start date:
2017-07-01
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Feature #77727: Use FormEngine for T3editor Closed 2016-08-31
Related to TYPO3 Core - Bug #81884: Downloading online media files in filelist not possible anymore Closed 2017-07-15
Related to TYPO3 Core - Bug #82436: Fix file upload and directory creation in file browser Closed 2017-09-10
Related to TYPO3 Core - Bug #83090: Save and close on file editing (from filelist) doesn't close Closed 2017-11-24
Related to TYPO3 Core - Bug #83151: Allow to upload online media via file list Closed 2017-11-29
Related to TYPO3 Core - Bug #83599: impexp: File upload in import broken Closed 2018-01-17

Associated revisions

Revision e6878c49 (diff)
Added by Andreas Fernandez over 2 years ago

[!!!][TASK] Migrate file edit form to FormEngine

To simplify the overhaul of EXT:t3editor, the form to change a file's
content is based on FormEngine now.

Additionally, the file rename form has been streamlined to the overall
backend visual appearance.

Resolves: #81763
Releases: master
Change-Id: Ifb9bc5513bff923a6d4cdbcb6046e87f4dcf3626
Reviewed-on: https://review.typo3.org/53129
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 8e57ff3b (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Fix media asset creation in filelist

After #81763, creating new media assets via "New file or folder" dialog
is broken. This patch fixes the broken behaviour.

Resolves: #81884
Related: #81763
Releases: master
Change-Id: Ifeb64705847c6c8ce3e5c0dea95a84ba828ef32e
Reviewed-on: https://review.typo3.org/53522
Reviewed-by: Manuel Selbach <>
Tested-by: Manuel Selbach <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision a81fb8a5 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Fix file upload and directory creation in file browser

While #81763 was in development, some locations of the file operation
handling were not adjusted. This patch fixes the left over places.

Resolves: #82436
Related: #81763
Releases: master
Change-Id: I450458f5ef687969b22a194a2387953330b8d17d
Reviewed-on: https://review.typo3.org/54094
Tested-by: Riccardo De Contardi <>
Reviewed-by: Benjamin Kott <>
Tested-by: Benjamin Kott <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 9f879047 (diff)
Added by Benni Mack over 2 years ago

[BUGFIX] Allow to upload online media via file list

It was not possible due to a form name mixup to add online media files
via the FileList in TYPO3 v9 anymore.

Related: #82436
Related: #81763
Resolves: #83151
Releases: master
Change-Id: Ica0ed049f685bf20b98f0a599adf61ec3874017a
Reviewed-on: https://review.typo3.org/54847
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 1246917a (diff)
Added by Christian Kuhn about 2 years ago

[BUGFIX] impexp: File upload in import broken

Uploading import files broke with patch for issue #81763
Fix by renaming POST array back from 'data' to 'file'.

Change-Id: I8de880775e2949951ef8a3f45b0a704c2ef3ac76
Resolves: #83599
Related: #81763
Releases: master
Reviewed-on: https://review.typo3.org/55385
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from In Progress to Under Review

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#2 Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#3 Updated by Christian Kuhn over 2 years ago

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#7 Updated by Gerrit Code Review over 2 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#8 Updated by Gerrit Code Review over 2 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53129

#9 Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Andreas Fernandez over 2 years ago

  • Related to Bug #81884: Downloading online media files in filelist not possible anymore added

#11 Updated by Andreas Fernandez over 2 years ago

  • Related to Bug #82436: Fix file upload and directory creation in file browser added

#12 Updated by Tymoteusz Motylewski over 2 years ago

  • Related to Bug #83090: Save and close on file editing (from filelist) doesn't close added

#13 Updated by Benni Mack over 2 years ago

  • Related to Bug #83151: Allow to upload online media via file list added

#14 Updated by Christian Kuhn about 2 years ago

  • Related to Bug #83599: impexp: File upload in import broken added

#15 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF