Bug #82444

EXT:form - huge spaces in form editor

Added by Bjoern Jacob about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Start date:
2017-09-10
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

1) Open the form editor.
2) Add a new form element to the stage.

The modal showing all of the avilable form elements is not displayed correctly. After each row of form elements, there is a huge gap. This problem only occurs in v8.

huge-space-bug.jpg View - screenshot with bug (41.4 KB) Andreas Steiger, 2017-09-18 10:50

without-bug.jpg View - screenshot without bug (40.8 KB) Andreas Steiger, 2017-09-18 10:50


Related issues

Related to Grid Elements (former official tracker) - now moved to Gitlab! - Bug #82502: EXT:form new elements wizard styles are overridden by t3skin_override.css Rejected 2017-09-18

Associated revisions

Revision fbf5650d (diff)
Added by Andreas Steiger over 1 year ago

[BUGFIX] EXT:form - fix design glitches of new element modal

Streamline the markup of the new element modal of the form editor and
fix some style glitches due to side effects with other extensions.

Resolves: #82444
Releases: master, 8.7
Change-Id: Ifceac76a70dd4744f52da3b08ca8baea5f4adb7d
Reviewed-on: https://review.typo3.org/55832
Reviewed-by: Björn Jacob <>
Tested-by: Björn Jacob <>
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision 3d38d40c (diff)
Added by Andreas Steiger over 1 year ago

[BUGFIX] EXT:form - fix design glitches of new element modal

Streamline the markup of the new element modal of the form editor and
fix some style glitches due to side effects with other extensions.

Resolves: #82444
Releases: master, 8.7
Change-Id: Ifceac76a70dd4744f52da3b08ca8baea5f4adb7d
Reviewed-on: https://review.typo3.org/55836
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54157

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54157

#4 Updated by Stefan Neufeind about 2 years ago

  • Status changed from Under Review to Rejected

not an issue of the TYPO3-core (not even in 8.7). It turned out during the review this appeared when EXT:gridelements was active.

#5 Updated by Riccardo De Contardi about 2 years ago

  • Related to Bug #82502: EXT:form new elements wizard styles are overridden by t3skin_override.css added

#6 Updated by Jo Hasenau almost 2 years ago

As described in #82502 the actual cause for the buggy behaviour is a superfluous <hr> tag with both top and bottom margins, which is accidentally "hidden" by the floated buttons. So the fix should be to remove or adjust that <hr>

#7 Updated by Susanne Moog almost 2 years ago

  • Status changed from Rejected to New

#8 Updated by Bjoern Jacob almost 2 years ago

Okay, we will check it again. Thx Jo for investigation.

#9 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55832

#10 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55832

#11 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55832

#12 Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55832

#13 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55836

#14 Updated by Andreas Steiger over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF