Bug #82888

Missing label in link browser

Added by Felix Paul almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2017-10-31
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
link browser; text editor; backend; ui; missing label
Complexity:
Is Regression:
Sprint Focus:

Description

As backenduser when setting a link in the text editor on a "text" content element I do:
-> Highlight text
-> Open link browser
-> go to "Page" tab
-> Missing label/text description in the highlighted area (see red marking)

bug.png (Screenshot of problem area (highlighted in red))

The required configuration for CKeditor in yaml is:

buttons:
  link:
    pageIdSelector.:
      enabled: 1

bug.png View - Screenshot of problem area (highlighted in red) (24 KB) Felix Paul, 2017-10-31 15:54

Schermata 2017-11-01 alle 11.21.38.png View (37.2 KB) Riccardo De Contardi, 2017-11-01 11:26


Related issues

Related to TYPO3 Core - Bug #82942: Wrong Links for pageids in rte_ckeditor in TYPO3 8.7.8 New 2017-11-07

Associated revisions

Revision e95feacb (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Add label to page ID field in PageLinkHandler

Add the missing label and adopt styling of the additional
field which allows to link to a page by providing the page ID.

Resolves: #82888
Releases: master, 8.7
Change-Id: I33ab92f235391add5d3da00a0251ee11eb936933
Reviewed-on: https://review.typo3.org/54575
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Jan Stockfisch <>
Tested-by: Henning Liebe <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision 8e107484 (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Add label to page ID field in PageLinkHandler

Add the missing label and adopt styling of the additional
field which allows to link to a page by providing the page ID.

Resolves: #82888
Releases: master, 8.7
Change-Id: I33ab92f235391add5d3da00a0251ee11eb936933
Reviewed-on: https://review.typo3.org/54635
Tested-by: TYPO3com <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Georg Ringer almost 2 years ago

Which name does the field have? Thanks for that information

#2 Updated by Riccardo De Contardi almost 2 years ago

Is there some TSConfig setting to enable the "CSS-class" and "Additional link parameters" fields in the link wizard of CKEditor?

I attach the screenshot of my wizard

#3 Updated by Fedir RYKHTIK almost 2 years ago

Just tested on TYPO3 9 - no such button (Chrome / Desktop).

#4 Updated by Georg Ringer almost 2 years ago

  • Status changed from New to Needs Feedback

are you using ckeditor or rtehtmlarea. can you also please add the name attribute of the field? thanks

#5 Updated by Felix Paul almost 2 years ago

Georg Ringer wrote:

are you using ckeditor or rtehtmlarea.

We are using the ckeditor

Georg Ringer wrote:

can you also please add the name attribute of the field? thanks

The name attribute of the input tag is "luid"

Hope this helps, thank you!

#6 Updated by Georg Ringer almost 2 years ago

  • Status changed from Needs Feedback to Accepted

ok the issue is in \TYPO3\CMS\Recordlist\LinkHandler\PageLinkHandler::modifyLinkAttributes but problem is not only the missing label but also that the feature "linking to a page by just providing the ID" does not create a correct link currently.

#7 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54575

#8 Updated by Georg Ringer almost 2 years ago

  • Related to Bug #82942: Wrong Links for pageids in rte_ckeditor in TYPO3 8.7.8 added

#9 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54575

#10 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54575

#11 Updated by Markus Klein almost 2 years ago

  • Description updated (diff)

#12 Updated by Markus Klein almost 2 years ago

  • Description updated (diff)

#13 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54635

#14 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF