Bug #83994

$uid must be positive integer, 0 given when creating a new Page

Added by Pascal Naujoks almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-02-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 Backend when i create a new page I receive the following Error:

#1437656456: $uid must be positive integer, 0 given (More information)

InvalidArgumentException thrown in file
.../httpsdocs/typo3_src-7.6.24/typo3/sysext/backend/Classes/Form/FormDataProvider/AbstractDatabaseRecordProvider.php in line 39.

In the Database a new record in the pages table is created with the UID 0.

Occures in TYPO3 7.6.23 and 7.6.24.

System:

Ubuntu 14.04.5 LTS (GNU/Linux 4.4.98-3-pve x86_64)
mysql  Ver 14.14 Distrib 5.5.59, for debian-linux-gnu (x86_64) using readline 6.3
PHP 5.5.9-1ubuntu4.23 (cli) (built: Feb  8 2018 21:59:47)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.6.0, Copyright (c) 2002-2014, by ionCube Ltd., and
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies


Related issues

Related to TYPO3 Core - Bug #84236: Uncaught exception in DataHandlerClosed2018-03-13

Actions
Related to TYPO3 Core - Bug #86933: $uid must be positive integer, 0 given when trying to edit multiple records in a workspaceClosed2018-11-15

Actions
#1

Updated by Michael Stucki almost 3 years ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Development)
  • TYPO3 Version set to 9

Wrong project.

#2

Updated by Christian Kuhn almost 3 years ago

  • Status changed from New to Needs Feedback

That's odd: Such a huge issue would pop up rather immediately.

I'm also unable to reproduce this locally on a v7 instance.

Would you please document how exactly you create the page? From the page module, the list module, the page tree? Do you always see this or just in some situations? Do you maybe have some extensions loaded that may trigger this issue? Maybe unload some extensions to see if the issue persists? Apart from that, usual mysql never creates a uid=0 in the database, so that is odd, too. Are you sure you really created a uid=0 record in the database?

#3

Updated by Manuel Thaler over 2 years ago

i See the same issue on TYPO3 v 7.6.24.

This happens after Migration from 6 to 7.6.24 in my case.
Actually as described here:
https://wiki.typo3.org/Exception/CMS/1437656456


#1437656456: $uid must be positive integer, 0 given (More information)

InvalidArgumentException thrown in file
/Users/manuel/Development/Source/Typo3Source/typo3_src-7.6.24/typo3/sysext/backend/Classes/Form/FormDataProvider/AbstractDatabaseRecordProvider.php in line 39.
#4

Updated by Andrej K over 2 years ago

I have the same issue, when I try to add new content element on any page.
You could see my environment and reproduction steps in https://forge.typo3.org/issues/84236

#5

Updated by Riccardo De Contardi over 2 years ago

  • Related to Bug #84236: Uncaught exception in DataHandler added
#6

Updated by Riccardo De Contardi over 2 years ago

Is this issue still present? - see also my comment on #84236

Thank you.

#7

Updated by Wouter Wolters about 2 years ago

  • Status changed from Needs Feedback to Closed

There have been some fixes in this area the last months for other DB drivers.
I close this issue because no feedback was given the last months.

#8

Updated by Georg Ringer 8 months ago

  • Related to Bug #86933: $uid must be positive integer, 0 given when trying to edit multiple records in a workspace added

Also available in: Atom PDF