Bug #84198

Epic #84044: Admin Panel Rework

simulate usergroup in admin panel is reset on update

Added by Riccardo De Contardi over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
AdminPanel
Target version:
Start date:
2018-03-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
frontend, admin panel, simulate usergroup, reload
Complexity:
Is Regression:
Sprint Focus:

Description

This issue is present only on 9.2.0-dev.

Steps to reproduce:

Prerequisistes

1) BE admin user > enable admin panel using admPanel=1 in his/her TSConfig field
2) FE usergroup "test group"
3) TypoScript Setup:

config.admPanel=1

Test

1) create a page
2) create a content element (e.g. Text With Images) ,write in a lot of text, in Access Tab set its "Usergroup Access Rights" as "test group"
3) Save and preview the page
4) Expand the admin panel (preview section) and set "Simulate user group" to "test group" and click "Update"
5) close the Preview Section of admin panel

Results

The dropdown "Simulate user group" does not hold the selected usergroup and becomes blank on the reload after clicking the "update" button.


Related issues

Related to TYPO3 Core - Feature #22564: The selected preview group in FE is not active if the admin-panel is not expanded.Closed2010-08-11

Actions
Related to TYPO3 Core - Bug #43672: Admin panel unnecessarily reloads page upon expand/collapseClosed2012-12-06

Actions
#1

Updated by Riccardo De Contardi over 2 years ago

  • Related to Feature #22564: The selected preview group in FE is not active if the admin-panel is not expanded. added
#2

Updated by Riccardo De Contardi over 2 years ago

  • Related to Bug #43672: Admin panel unnecessarily reloads page upon expand/collapse added
#3

Updated by Riccardo De Contardi over 2 years ago

#4

Updated by Susanne Moog over 2 years ago

  • Parent task set to #84044
#5

Updated by Susanne Moog over 2 years ago

  • Category changed from Frontend to AdminPanel
#6

Updated by Susanne Moog over 2 years ago

  • Target version set to 9 LTS
#7

Updated by Riccardo De Contardi over 2 years ago

This issue is still reproducible on 9.4-dev (latest master) after the admin panel rework.

#8

Updated by Susanne Moog about 2 years ago

  • Assignee set to Susanne Moog
#9

Updated by Frank Naegler about 2 years ago

  • Status changed from New to In Progress
  • Assignee changed from Susanne Moog to Frank Naegler
#10

Updated by Gerrit Code Review about 2 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58329

#11

Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58330

#12

Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58330

#13

Updated by Frank Naegler about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF